home

MPC-ESTWin

Beispiel eines ESTW (Lupendarstellung)

Dieses Programm soll eine möglichst reales "Elektronisches Stellwerk" für die Hardware der MpC-Steuerung nachbilden. MpC ist die "Modellbahnsteuerung per Computer" von Gahler und Ringstmeier (www.gahler.de). Die Hardware ist über eine ISA-Karte an einen PC angeschlossen, das Programm selbst läuft unter DOS und besitzt eine zweckmäßige Bedienoberfläche, ein Bildschirmstellwerk fehlt leider.

Für meine Zwecke und zum Hobby entwickle ich nun eine grafische Oberfläche nach ESTW-Vorbild. Das Programm ersetzt bei mir inzwischen die MPC-Steuerung. Für besondere Test nutze ich noch die MPC (3.6), insbesondere das Prüfprogramm. Der Stand der Züge konnte zwischen beiden Programmen ausgetauscht werden (nur 3.6).

Eine Kombination der MPC-Software mit einer grafischen Oberfläche wäre eine wünschenswert, aber DOS und Windows XP (Am Start der Entwicklung, inzwischen läuft das Programm auch unter Vista und Windows 7, Windows 8 noch nicht getestet) das ist wohl eine schwierige Kombination; noch dazu, wenn beide auf den gleichen Datenbestand zugreifen müssen.

Beispiel eines ESTW (Bereichsübersicht)

Deshalb habe ich mich entschlossen beides in einem Programm zu verwirklichen, zumal die Ansätze der Steuerung sich doch deutlich unterscheiden: Signale sind bei der MPC eher Nebensache, beim ESTW der Kern der Steuerung. Beim ESTW wird grundsätzlich von Signal zu Signal gefahren, dabei kannn ein Signal auch "nur" ein Start- oder Zielpfeil sein. Allerdings können Zugstrassen nur an einem Signal beginnen. Für Rangierstrassen genügt auch ein Pfeil

Vor ein paar Jahren hatte ich mal Studien mit einer Steuerung für die MPC gemacht, zwei Züge fuhren auch schon im Kreis. Das sollte die Basis für ein grafisches Steuerprogramm sein. Mit der Programmierung habe ich Anfang 2006 begonnen, das Programm ist inzwischen 2015 ausgereift: Meine Version ist bei 1.2.5 angekommen und die Züge können gleichzeitig fahren. Es gibt in Zukunft nur noch eine Fehlerbereinigung und wenn nötig kleine Erweiterungen

Referenzen

Für die Entwicklung dieses Programms habe ich die folgenden Quellen verwendet:
  • Dokumentationen der MPC-Steuerung (www.gahler.de)
  • SpDr60-Stellwerke bedienen, Ferdinand Hein (Eisenbahn-Fachverlag), ISBN 3-9801093-0-5
  • Elektronische Stellwerke bedienen, Walter Jonas (Eisenbahn-Fachverlag), ISBN 3-9808002-0-2
  • Handbuch der ESTW-Funktionen, Hans-Joachim Zoeller (Eurail press), ISBN 3-87814-802-X
Auf den folgenden Internetseiten findet man ebenfalls viele Informationen und Erklärungen:
  • ESTWsim Realistische Stellwerkssimulationen (www.estwsim.de)
  • Alles über Stellwerke (www.stellwerke.de)
  • Modellbahn-eSTW (www.estw.eu)
Bearbeitet am 14.05.2015


Voraussetzungen

Für die Nutzung des Programms unter Windows XP, NT, 2000 oder Vista ist ein spezieller Treiber für die Hardware erforderlich. Das ist ein Treiber von www.zealsoft.com (Shareware) Dieser Treiber ist für die Verwendung mit diesem Programm lizensiert, ebenso der Treiber ntport.sys.

Unter Windows XP, NT, 2000 und Vista muss der Treiber ntport.sys installiert sein, wie das gemacht wird, steht in der ReadmeNT.txt. Die dll muss im gleichen Verzeichnis wie das Programm liegen.

Ohne die dll und ohne den Treiber startet das Programm nicht bzw. bricht mit einer Fehlermeldung ab.

Für die Benutzung zusammen mit der MPC-Hardware sollte eine ausreichend schneller Rechner im Einsatz sein. Zurzeit benötigt der Rechner noch einen ISA-Steckplatz. Geeignete Rechner und oder Boards gibt es bei Alptech (www.alptech.de), das sind Rechner der neuesten Generation Dual-Core, Quad-Core, Grafik-Express usw.

Inzwischen funktioniert auch die LPT-Schnittstelle mit diesem Programm. Die ist aber deutlich langsamer als die ISA-Karte (analog zur MpC). Ob das die Funktionalität entscheidend einschränkt, kann ich nicht sagen. Mit wenigen Zügen gleichzeitig gab es bisher keine Probleme.

Bearbeitet am 14.10.2009


Tutorial

Tutorial MPC-ESTW

Vorbereitungen

Das Programm mit folgenden unbedingt erforderlichen Teilen in ein separates Verzeichnis kopieren:
- Mestw0.exe (Programm)
- mpc-estw.chm (Hilfedatei)
- ntport.dll (Library für die Treiber)
Die Textdateien spielen keine Rolle, die Dateien Aktuell.* sind Datendateien, die ini-Datei enthält die Basiskonfiguration und wird nur benötigt, wenn die Grundeinstellung verändert wird. Dieses Tutorial benötigt keine Hardware. (sollte auch nicht aktiv sein)

Erster Programmstart

Programm Programm starten, es folgt ein Hinweis auf den Simulations-Modus, weil keine Porttreiber (ntport.sys) installiert ist. (Sollte der Porttreiber bereits installiert sein, bitte auf der Konfiguration Seite "MPC 2" den Schalter Hardware drücken) Auf dem Bildschirm muss neben dem Abbrechen-Knopf der Vermerk "Simu" stehen.

Überblick

Auf der rechten Seite des Bildschirms erscheinen später die Züge. Unten rechts gibt es einen Fahrregler. Der große schwarze Bereich enthält später die Gleisbilder. Unten im Bild befindet dich der ESTW-typische Bereich für die Bedienung des Stellwerks. Im Kästchen "MPC-Hardware" wird der Betrieb ein- und ausgeschaltet, und dort befindet sich der General-Nothalt-Knopf.

Lebenszeichen Wir schalten einmal "MPC-ein", der Betrieb erwacht. Links unten erwacht jetzt das Lebenszeichen im Sekundentakt. Auf der Tastatur einmal z.B. "abc" eintippen. In der Zeile "EIN:" wie Eingabe steht jetzt "ABC", der Verarbeiten- und der Abbrechen-Knopf sind bedienbar. Der Befehl in der Eingabezeile wird mit "Verarbeiten ausgeführt" und da es keine gültiger Befehl ist abgewiesen, "VQ" = Verarbeiten quittieren. Wir schalten die MPC wieder aus, das Lebenszeichen stoppt und unter "VQ" steht jetzt in Gelb eine Info. Das ist eine interne Informationszeile für das Programm oder sonstige Infos.

In der Zeile "BDG" sollte dieser Text mit dem Lupenbild wechseln (ist aber noch nicht realisiert). Dahinter stehen Alarme und Meldungen, nur wenige haben z. Zt. eine Funktion. "ZW:" ist das Zählwerk (noch ohne Funktion). Dann gibt es noch das Datum und darunter eine Anzeige, welches Bild gerade aufgeschaltet ist. Wofür steht eigentlich "ST"? jedenfalls tauchen bei Bedarf dahinter Meldungen auf, z.B. die Kurzschlussmeldungen. Beim ESTW unterscheidet sich der Seitenaufbau für Lupe und Berü geringfügig, hier noch nicht.

Zielvorgabe

Gleisplan Als Ziel für dieses Tutorial nehmen wir einen einfachen Kreis mit einem zweigleisigen Bahnhof. Der Bedarf an MPC-Hardware dafür wären 2 Blockkarten, 1 Hilfsblockkarte, 2 Belegtmelderkarten.
Im Plan ist die Funktion der Belegtmelder mit M für Melder, H für Haltepunkte und B für Bremspunkte eingetragen. 301 und 302 sind Pseudoblöcke, aber dazu später mehr. Der Kreis kann in beiden Richtungen gefahren werden.

weiter auf Seite 2

Neu am 9.07.2007


Allgemeines

Allgemeines zur ESTW-Steuerung

In diesem Kapitel wird eine Übersicht über das Programm gegeben:

  • Das Programm starten.
  • Das Hauptfenster im Überblick
  • Das Fahrpult im Hauptfenster.
Neu am 26.06.2007


Programmstart

Nach dem ersten Programmstart (ohne Hardware) muss zunächst die Grundkonfiguration eingestellt werden. Danach müssen die Gleisbilder entworfen, erste Fahrstrassen definiert und Züge eingegeben werden.

Der Programmstart funktioniert jetzt auch ohne vorher die MPC-Steuerung genutzt zu haben. Die Initialisierung entspricht jetzt der MPC, der SNT schaltet nun auch zuverlässig (An dieser Stelle ein herzliches "Dankeschön" an Herrn Ringstmeier für die Unterstützung).

Inzwischen funktionieren beide Schnittstellen, die ISA-Karte und die LPT-Karte. Als Standard ist die ISA eingestellt, der ISA-Port kann noch nicht verändert werden. Für die LPT-Karte kann die zugehörige Adresse eingestellt werden.

Nach dem Programmstart kann man Daten laden: Im Menü Datei gibt des die Möglichkeit nur die Daten zu laden und zu sichern, das ist die komplette Konfiguration. Zusätzlich kann die Betriebssituation, das ist die Position der Züge, geladen oder gesichert werden. Der Punkt "Alles laden" lädt sowohl die Daten als auch die Betriebssituation, das ist im Unterschied zu Daten laden ein eingefrorener Betriebszustand. Wenn nur die Daten geladen werden, werden alle Melder in Grundstellung versetzt. Anschließend kann der Betriebszustand separat dazu geladen werden (das ist dann nur die Position der Züge).

Wenn sich Züge auf der Anlage befinden, sollte grundsätzlich mit Alles laden bzw. sichern gearbeitet werden. Beim Nachladen der Betriebsdaten sind einige Einstellung auf die Grundstellungen zurückgesetzt, das entspricht einem ersten Aufstellen der Züge. Falls vorhanden werden auch Fahrplandaten geladen.

Die Funktionen Laden direkt und Sichern direkt habe ich später zur Vereinfachung nachgerüstet. Es wird der zuletzt verwendete Dateiname verwendet, der steht auch in der Titelzeile.

Bearbeitet am 14.05.2015


Hauptfenster

Das Hauptfenster der Anwendung

Hier ist das Hauptfenster der Anwendung dargestellt. Es gliedert sich in mehrere Bereiche, Menüleiste (oben), Zugliste (rechts), Eingabe- und Melderbereich (unten links), Lokdaten- und Steuerung (unten rechts). Den größten Bereich in Bildmitte nimmt die Darstellung der Gleise ein. Das können verschiedene Detail-Bilder (Lupe) oder Bereichsübersichten (Berü) sein.

Zwischen den einzelnen Ansichten kann mittels Richtungstasten gewechselt werden: Mit Rechts/Links bewegt man sich durch die Seiten. Mit Oben/Unten schalten man zwischen Lupe und Berü um, gefolgt von Rechts/Links. Bei erstmaligem Programmstart muss zunächst die Konfiguration erfolgen oder eine Beispieldatei geladen werden.

Für die Erstellung der Grafiken kann wahlweise ein Raster hinterlegt werden. Auf der Lupendarstellung liegt 10 Pixel Raster mit Hauptlinien alle 40 Pixel. Auf der Berü haben die Hauptlinien einen Abstand von 30 Pixel. Die Elemente können auf Wunsch (Config-Seite) auch mit den Cursortasten bewegt werden. Für den normalen Betrieb sollte diese Option abgeschaltet sein.

Bearbeitet am 14.05.2015


Eingabebereich

Eingabe- und Meldebereich im Hauptfenster

Hier stehen die typischen Bedienelemente eines ESTW: Die Taste "Verarbeiten" führt die in der Zeile "EIN" eingegebenen Befehle aus. Die Taste "Abbrechen" löscht eine Eingabe. Die Taste "Rücknehmen" nimmt einen bereits zur Verarbeitung freigegeben Befehl zurück (in diesem Programm nicht erforderlich und daher auch nicht aktiv). "Quittieren" dient zum Quittieren von auflaufenden Alarmen - zur Zeit selten erforderlich.

Die Kommandofreigabetasten "KF1" und "KF2" dienen der Freigabe von bestimmten Befehlen, z.B. bei der Rücknahme von Fahrstrassen. Es werden noch Befehle mit und ohne Zählung unterschieden. Bei einem echten ESTW müssen die Freigabetasten in einem vorgegebenen Zeitfenster betätigt werden, sonst wird der Befehl zurückgewiesen.

Links unten bewegt sich ständig ein Farbbalken und ein Strich dreht sich, das sind die Lebenszeichen des Programms, darunter steht das Logo.

Zu den Textzeilen: "BDG" steht für den 1. Bahnhof auf der Lupe und wechselt mit der Lupe und der Berü. Dahinter steht eine Liste mit Meldungen und Alarmen. Bisher wird nur eine Meldung angesteuert.

NA und TA stehen für Nacht- bzw. Taganschaltung, EV steht für Stromversorgung, SB für aktivierten Selbststellbetrieb, ZL für aktivierten Zuglenkungsbetrieb, WL für die Weichenlaufkette (blinkt, wenn Fahrstrassen gestellt werden), SS für eine Signalstörung, BU für einen gestörten Bahnübergang, VA für Eingabeverarbeitung. Hinter VA wird zeitweise eine Zahl angezeigt (flackert etwas), Das ist die Anzahl der Stellbefehle in der Warteliste.

In der EIN-Zeile werden die Befehle vor der Verarbeitung angezeigt. Darunter steht die VQ-Zeile, das bedeutet Verarbeitung quittiert. Diese Zeile zeigt verarbeitete Befehle und Hinweise. Dann werden noch das Datum und die Lupe- oder die Berü-Nummer angezeigt. In der ST-Zeile erscheinen Störungsmeldungen, zur Zeit nur Kurzschlussmeldungen.

Ganz unten stehen noch die Schalter für die MPC-Hardware: Ein/Aus und Generalnothalt.

Neu am 14.05.2015


Zugliste

Zugliste im Hauptfenster

Rechts im Hauptfenster befindet sich die Zugliste. In dieser Liste stehen alle aktiven Züge mit dem aktuellen Standort des Zuges, ein "x" steht für einen fahrenden Zug. Wenn viele Züge in der Liste sind erscheint automatisch eine Scrollbar.

Mit der Maus kann ein Zug angewählt und in den unten aufgeführten Fahrregler übernommen werden.

Ein deaktivierter Zug steht nicht in dieser Liste, auch wenn er in einem Block gepart wurde.

Neu am 14.05.2015


Fahrpult

Das Fahrpult in der Bedienoberfläche

Das Fahrpult Zeigt viele Informationen zum angewählten Zug an. Ein Zug wird durch anklicken in der Zugliste ausgewählt, oder mittels Tastaturbefehl '#F126' (126 ist der Zug), oder im Stellpult mit der Blocktaste und der Sterntaste (analog MPC). Die Befehle entsprechen den MPC-Befehlen, nur muss ein '#' vorgestellt werden.

Oben steht neben der Zugnummer der Name des Zuges gemäß Konfiguration. Mit der Taste 'Zug' kann ein Zug eingesetzt oder entfernt werden. Ein Klick auf den Text "Zug-Nr." aktiviert oder deaktiviert einen Zug. Der Schriftzug wird für einen deaktivierten Zug rot dargestellt und der Zug aus der Zugliste entfernt. Diese Funktion ist für Züge im Paternoster gedacht. Wird eine Fahrstrasse aus dem Paternoster heraus eingestellt, so wird der dort befindliche Zug automatisch in den Fahrregler übernommen und kann aktiviert werden. Wenn ein Zug den MpC-Bereich verläßt sollte er ebenfalls deaktiviert werden

In der zweiten Zeile erscheinen die für den Zug eingestellten Fahrstrassen. Im Moment nur maximal zwei. Darunter ist die Blockfolge aufgeführt, belegte Blöcke jeweils grün oder rot; nur die ersten sieben - intern sind 20 möglich. Darunter sind die aktuell wirksamen Halt- und Bremspunkte angezeigt. Es folgen Soll- und Istgeschwindigkeit. Die Geschwindigkeit wird zusätzlich noch als Zahl angezeigt. (hier 62)

Das Sperrsignal schaltet zwischen Rangierfahrt und Normalfahrt um. Bei Rangierfahrt werden alle Brems- und Haltepunkte ignoriert, das entspricht dem Handbetrieb bei der MPC. Der Schriftzug "Halt" aktiviert oder deaktiviert den Einzelnothalt. Über des Symbol "KU" wird die Funktion "Kurzzug" ein- und ausgeschaltet. Die Pfeiltaste schaltet die Fahrtrichtung um. Daneben erscheinen noch zur Info Punkte, die Anzeigen, ob ein Haltepunkt oder Schleichfahrt aktiv sind. Auch ein Hinweis "Hp2" wird eingeblendet, wenn aktiv.

Hinzugekommen sind jetzt noch ein kleines Panel mit den Fahreigenschaften zur einfachen Information. Dieses Panel kann im Menü unter dem Punkt Anzeige ein- oder ausgeblendet werden. Fahreigenschaften werden in der Konfiguration oder am Stelltisch oder als Textbefehl eingegeben.

Im Stellpult funktionieren bereits die folgenden Tasten:
- Geschwindigkeitstasten und LED 0-15
- Rangiertaste und LED
- KU-Taste und LED
- Fst.halten-Taste und LED
- Zug-Inaktiv-Taste und LED
- Generalnothalt und LED (nur einfacher Tastendruck)
- Einzelnothalt und LED
- Richtungstasten und LED
- +/- Tasten (schneller / langsamer)
- a, b, c, s, h2, h3, o, u-Tasten in Kombination mit dem 12er-Block
- 12er-Block und 7-Segmentanzeige (Fahrregler und Eingaben)
- Drehregler

Aktualisiert am 14.05.2015


Zugspeicher

Der Zugspeicher ist eine spezielle Liste, in der alle deaktivierten Loks (Fahrzeuge) stehen. Der Zugspeicher kann, muß aber nicht genutzt werden. Der Speicher runterstützt auch die Funktionen
- Fahren von/nach extern,
- Paternosterfunktion (auch manueller P.)
- Züge einfach nur "Inaktiv"

Der Vorteil von inaktiv geschalteten Zügen ist, dass diese Züge nicht mehr in der Zugliste und im Hauptfenster geführt werden. Die Gleise auf der Anlage bleiben aber besetzt, diese Züge sind abgestellt.

Die Funktionen "Fahren nach extern" und "Paternoster" wende ich in Kombination an.
Zur Extern-Funktion gehört ein spezieller Block mit der Nummer 600. Auf dem Bild links ist dieser Block mit E/A gekennzeichnet. In diesem Block erscheinen alle Züge aus einem Paternostergleis, diese haben den Nummernbereich 456 - 599.

Im Speicher befinden sich alle deaktivierten Züge:
- Züge auf im MPC-Bereich haben einen realen Block > 001-455
- Züge im Paternoster haben einen Paternosterblock > 456-599
- Sonstige definierten Züge haben den Block "0".

Durch Anklicken eines Zuges im Zugspeicher mit dem Block "0" wird dieser Zug (Lok) auf den Block 600 gesetzt, wenn dieser Block keinen Zug hat und belegt ist. Bei mir repräsentiert dieser Block alle Ein- und Ausfahrgleise aus dem Betriebswerk. Die notwendige Besetztmeldung wird mittels einem Schalter erzeugt, der an eine Belegtmelderkarte angeschlossen ist. Das Vorgehen ist wie folgt:

  • Belegtmeldung aktivieren (Schalter im Stellpult)
  • Zug erscheint im Fahrregler und im Block 600, wenn der Zug keinen Block (0) hat
  • Zug aktivieren (Text Zugnummer oder Tater im Stellpult)
  • Fahrstrasse aus dem BW einstellen (bei mir)
  • Zugtempo und Richtung einstellen, dann aus dem analogen Bereich zur MPC fahren
  • Belegtmeldung Block 600 ausschalten, sonst wird die Fahrstrasse nicht aufgelöst.

Fahren von der MPC nach analog:

  • Fahrtrasse zum BW einstellen
  • Zug zum BW (extern) fahren und analog weiterfahren
  • Belegtmeldung für den Block 600 aktivieren.
  • Belegtmeldung für den Block 600 ausschalten
  • Zug deaktivieren, der Zug verschwindet aus dem Block 600 und wird im Zugspeicher geführt.

Neu am 14.05.2015


Konfiguration - allgemein

Die Konfiguration erfolgt in diesem speziellen Fenster. Die Grundkonfiguration der Hardware erfolgt auf der nächsten Seite

Bearbeitet am 29.05.2007


Config

Konfiguration - Configseite

Basiskonfiguration

Auf der Config-Seite müssen die Grundeinstellungen für die Anlage vorgenommen werden. Die meisten Einstellungen betreffen die Hardware. Diese Einstellungen werden in einer "Ini"-Datei gesichert.

Zusätzlich wird die Anzahl der Lupen- und Berü-Seiten festgelegt. Zusätzlich zu diesen Seiten gibt es immer noch jeweils eine Seite 0. Diese Seiten sind nicht sichtbar und nehmen nicht benötigte Darstellungen auf.

Als weiteres Vorgehen sei die folgende Reihenfolge empfohlen:

  • Blöcke, Weichen, Haupt- und Blocksignale sowie Bahnübergänge anlegen
    (diese Elemente besitzen Gleisbausteine)
  • Gleise besitzen ebenfalls Gleisbausteine und werden bei Bedarf zum Verknüpfen benötigt.
  • Belegtmelder definieren
  • Zum Fahren werden noch Fahrstrassen und Züge benötigt
  • Zur Vervollständigung können noch grafische Elemente hinzugefügt werden (Sonstiges)
  • Eingleisige Strecken müssen zusätzlich definiert werden.
  • Trennstellen müssen ebenfalls zusätzlich definiert werden.
  • Als letztes können noch Taster definiert werden

Um die Hardware testen zu können muss mindestens 1 Block mit Haltepunkten (Belegtmelder) und 1 Zug angelegt sein, der Zug kann dann im Block hin- und herfahren. Für eine erste Fahrt sind ein 2. Block, mindesten 2 Signale (Start/Ziel) und 1 Fahrstrasse erforderlich. Für Hin- und Rückfahrt benötigt man 4 Signale und 2 Fahrstrassen. Im Gegensatz zur MPC kann eine Fahrstrasse nur in einer Richtung definiert werden(!)

Der Bereich Zeitgeber ist nur vorsichtig zu verändern: Hier stehen Zeitangaben, die vorgeben wie oft ein bestimmter Programmbereich durchlaufen werden soll. Die Zeit für Bel.-Melder bestimmt die Abfrageintervalle für aller Melder. Fahren gibt das Intervall für die Schleife "Zug fahren" an, das beeinflusst auch die Beschleunigung und das Bremsen sowie die Reaktionszeiten! Für die Tasterabfrage können höhere Werte vorgegeben werden. Für den Drehregler sind kleine (max. 10 ms) Werte notwendig, da dieser sonst ruckelt.
Diese Einstellungen bitte nur in kleinen Schritten verstellen!

Es kann zwischen zwei Schnittstellen gewählt werden, der normalen "alten" ISA-Karte und der neueren LPTKarte. Für die LPT-Schnittstelle muss die korrekte Basisadresse eingestellt sein, der LPT-Port. Auf die Angaben LPT1, LPT2 usw. wurde bewusst verzichtet, weil diese Angaben unter Windows nichts über die Adresse aussagen. Die Adresse kann man aus der Systemsteuerung entnehmen.

Über die Taste „Texte“ wird ein zusätzliches Fenster eingeblendet. Dort werden die Texte für die Lupen und die Berü eingetragen. Diese Einstellungen dienen nur der Optik und haben keine weitere Funktion.

Fotos anzeigen zeigt im unteren Bereich Fotos der Fahrzeuge an. Die Fotos müssen in Pfad ../Fotos/ als Znnn.jpg hinterlegt sein, Größe 408 x 121 Pixel. nnn ist die Nummer das zugehörigen Fahrreglers ohne führende Nullen (Z1.jpg bis Z400.jpg)
Farben Hiermit können die Farben des Fensters verändert werden.

Im Bereich Optionen können verschiedene Vorgaben abgeändert werden:
Stop bei Richtungswechsel bedeutet, das eine Lok, die am Ende eines Blockes bei einem Richtungswechsel nicht zum anderen Blockende fährt.
Gleise mit Belegtmelder ermöglicht eine feinere Anzeige der Belegmeldung für Gleise, wenn für die Gleise ein Belegtmelder eingetragen ist.
Pause bei Richtungswechsel legt fest wie Lange ein Zug wartet, wenn während der Fahrt die Fahrtrichtung umgeschaltet wird.
Rangier. direkt Gewindigkeitsänderungen werden im Rangiermodus direkt an die Fahrzeuge gegeben ohne Berücksichtigung der eingestellten Eigenschaften.
Raster ein zeigt ein Raster als Hintergrund, die Hauptlinien sind im Abstand der Gleise dargestellt: 40 Pixel für Lupenanzeige und 30 für die Berü.
Edit Modus ein erlaubt das Verschieben und Größenänderung der Elemente mit den Cursortasten nach folgender Tabelle:

Tasten | Block | Gleis | Weiche | Trennst. | Signal | BÜ | Sonst. | Eingl.S.
links | X-1 | X-1 | X-1 | X-1 | X-1 | X-1 | X-1 | X-1
rechts | X+1 | X+1 | X+1 | X+1 | X+1 | X+1 | X+1 | X+1
oben | Y-1 | Y1-1 | Y-1 | Y-1 | Y-1 | Y-1 | Y-1 | Y-1
unten | Y+1 | Y1+1 | Y+1 | Y+1 | Y+1 | Y+1 | Y+1 | Y+1
Sh links | Länge-1 |  | Spitze-1 |  | Länge-1 | Länge-1 | Länge-1 |
Sh rechts | Länge+1 |  | Spitze+1 |  | Länge+1 | Länge+1 | Länge+1 |
Sh oben |  | Y2-1 | Abst.-1 |  |  | LängeM-1 |  |
Sh unten |  | Y2+1 | Abst.+1 |  |  | LängeM+1 |  |
Seite oben |  | LängeT-1 | LängeG-1 |  |  |  |  |
Seite unten |  | LängeT+1 | LängeG+1 |  |  |  |  |
Sh S. oben |  | Länge-1 | LängeA-1 |  |  |  |  |
Sh S. unten |  | Länge+1 | LängeG+1 |  |  |  |  |

Bearbeitet am 14.05.2015


Block

Konfiguration - Blockseite

Hauptgleise - Eingabetabelle

Auf der Blockseite werden alle Hauptgleise definiert. Der Nummernbereich liegt zwischen 1 und 455 mit folgender Aufteilung:

  • Bereich 001 - 200 für Hauptblöcke mit der zugehörigen Hardware (Blockkarten)
  • Bereich 201 - HHH für Hilfsblöcke mit der zugehörigen Hardware (Hilfsblockkarten)
  • Bereich HHH - 455 für Pseudoblöcke ohne eigene Hardware, benötigen aber mindestens 1 Belegtmelder.
  • Bereich 456 - 599 für Paternosterblöcke
  • Block 600 Spezial für Fahrten nach Extern

Bedeutung der zugehörigen Felder:

  • MPC-Gruppe
    • Block-Num = Blocknummer entsprechend der Hardware
    • Hauptblock = Blocknummer, bei Hauptblöcken 0; bei Hilfsblöcken die Nummer des Hauptblocks, der die Stromversorgung übernimmt; bei Pseudoblöcken die Nummer des zugehörigen Hauptblockes oder Hilfsblockes, der die Stromversorgung abgibt.
    • Taster = Nummer eines Tasters der MPC (oder 0)
    • Belegt-Led = Nummer einer Led der MPC (oder 0)
    • Fahrstr.-Led = Nummer einer Led der MPC (oder 0)
    • Vmax = Zulässige Höchstgeschwindigkeit im Block (oder 0)
    • Korrektur = Korrektur der Geschwindigkeit für den Block (+5 bis -5) entspricht +/-50%
    • HPr/HPv = Haltepunkte vorwärts/rückwärts (Belegtmelder)
    • BPr/BPv = Bremspunkte vorwärts/rückwärts (Belegtmelder)
    • Kurzzugeinstellungen = Aktiviert den Block für Kurzzüge
    • HPr/HPv = Haltepunkte vorwärts/rückwärts (Kurzzug-Belegtmelder) bei einer Eingabe von 0 ist der Block der Haltepunkt.
    • BPr/BPv = Bremspunkte vorwärts/rückwärts (Kurzzug-Belegtmelder)
    • Signal Idx = Index-Nummer eines projektierten Signals pro MPC-Fahrtrichtung. Diese Angabe wird nur für die Bildschirmanzeige der Gleiselemente eines Signals der Typen 0 bis 5 benötigt.
  • Automatik-Gruppe
    • Aw.Fst. v/r = Bei Automatikbetrieb steht hier eine Ausweichfahrstrasse (z.B. im Schattenbahnhof) je Fahrtrichtung
    • Schalter v/r = Automatik ein- oder ausschalten. (1000 = dauerhaft ein)
    • Ausf.-Fst. v/r = Automatische Ausfahrt über die eingetragene Fahrstrasse (Staffellauf oder Weiterfahrt)
    • Schalter v/r = Schalter, die die Automatik ein- oder ausschalten. (1000 = dauerhaft ein)
    • Verzöger. = Mögliche Verzögerung bis zum Schalten der Fahrstrasse.
    • Alt.-Block = Ein alternativer Block, aus dem ausgefahren werden soll (Staffellauf).
    • Ziel muss frei sein = Ist dieser Schalter gesetzt, wird keine Fahrstrasse gestellt, wenn das Ziel besetzt ist, ansonsten wird die Fahrstrasse vorgemerkt.
  • ESTW-Gruppe
    • Lupe/Berü = Das Element wird auf der entsprechenden Seite gezeichnet (Wert 0 = keine Anzeige
    • Position X = Beginn des Gleiselementes (linke Seite) auf dem Bild
    • Position Y = Höhenmitte auf dem Bild
    • Länge = Länge des Gleiselemente (Pixel)
    • Typ = Art des Elementes (siehe unten)
    • Bereich = Zugehörige Bahnhof-Nummer
    • Gleis-Bez = Gleisnummer oder andere Bezeichnung (Text)
    • Zugnummer = Anzeige auf dem Bildschirm (Gleis-Bez oder Zug-Bez), wird vom Programm geändert
    • Invert = MPC-Fahrtrichtung normal von Links nach Rechts, wenn gesetzt, dann umgekehrt.
    • Gleis = Wenn gesetzt sind keine Sperr- und Festlegemelder vorhanden.
    • Zug-Nr. n.a. = Wenn gesetzt entfällt der Zugnummernanzeiger
  • Blaue Felder werden vom Programm genutzt
    • Index = Interne Nummer der Grafikelemente, in der Reihenfolge der Erstellung.
    • Status = frei (kein Bit), belegt (Bit 1), Fahrstrasse (Bit 2), Rangierstrasse (Bit 3)
    • Zughalt = weiss (0), rot (1), gelb (2)
    • VsM = Verschlussmelder
    • ZFM v/r = Zielfestlegemelder vorw./rückw.
    • Fahrstr. S/Z = Gleis ist Start oder Ziel der angegebenen Fahrstrasse
    • Akt./Vorm. = Zug (Nummer) ist aktuell im Block / ist vorgemerkt
    • HBlo = Der Block versorgt einen Block mit dem Zug der Nummer
    • FRi = Genutzte Fahrtrichtung: 0 frei, 1 vorw., 2 rückw.
    • Richt. Sig. belegt = Bildschirmbezogene Fahrtrichtung für die Darstellung des Signalgleises

Es gibt die folgenden Blocktypen. Der Typ 3 ist neu, dadurch ist es möglich, auch Modellanlagen als Kreis darzustellen. Normalerweise muß bei diesem Typ auch der Schalter Invert gesetzt sein, weil das Zielsignal normalerweise in Gegenrichtung steht.

  • Typ 0 ist das normale Hauptgleis
  • Typ 1 ist ein einfaches weißes Gleis
  • Typ 2 ist ein weißes gestricheltes Gleis
  • Typ 3 entspricht Typ 0, nur senkrecht (entspricht nicht ESTW)

Position und Länge können mit den Cursortasten verändert werden, wenn diese Option auf der Configseite aktiviert ist. Die Werte in den zugehörigen Feldern zählen jeweils um 1 Pixel rauf oder runter.

Hier die Darstellung der verschiedenen Typen, alle Typ 0 außer, die beiden Letzten sind vom Typ 1 und 2
Die Gleisdarstellung auf der Lupe ist links gezeigt, die auf der Berü rechts:
1 ist die normale Darstellung Status frei;
2 ist ein einfaches Gleis ohne Melder;
3 ist belegt;
4 ist eine Fahrstrasse;
5 ist eine Rangierstrasse;
6 Fahrstrasse Verschlussmelder und Zielfestlegemelder links sind eingeschaltet.
7 Fahrstrasse Verschlussmelder und Zielfestlegemelder rechts sind eingeschaltet.

Hauptgleis neu anlegen

Wichtig: Bevor der Schalter "Neu" betätigt wird müssen in die Felder Lupe und Berü die richten Werte eingetragen sein. Aus Bereich und Signal-Bez. bildet das Programm einen eindeutigen Schlüssel (Key). Auf Lupe und Berü wird gezeichnet, dafür wird vom Programm jeweils ein Objekt erzeugt.
Änderungen dieser Felder werden vom Programm zur Laufzeit zwar angenommen, aber erst nach einem Neustart umgesetzt (Daten sichern nicht vergessen).

Bearbeitet am 14.05.2015


Gleise

Konfiguration - Gleisseite

Neben- und Verbindungs-Gleise - Eingabetabelle

Auf der Seite Gleise werden alle Nebengleise und Gleisverbindungen eingetragen, die für die eigentliche MPC-Steuerung nicht erforderlich sind. Diese Elemente werden nur wegen der Darstellung auf dem Bildschirm benötigt. Das sind einfache Geraden, Gleisversatz und Kurvenelemente. Diese Elemente sind in ihrer Anzahl nicht begrenzt, die Nummerierung beginnt bei Null (da es sich um offene Arrays handelt). Deshalb werden in den anderen Tabellen nicht vorhandene Elemente mit -1 belegt.

Die Eingabe von "-1" im Feld Melder hat aber eine andere Bedeutung: In diesem Fall wird das Gleis nur in Abhängigkeit von der Fahrstrasse ausgeleuchtet. Ein "0" in diesem Feld bedeutet eine direkte Abhängigkeit vom Block, eine Meldernummer ebenfalls eine Abhängigkeit vom Block. Je nach eingestellter Option auf der Config-Seite wir die Belegtmeldung zusammen mit dem Block oder abhängig vom Belegtmelder angezeigt, was eine feinere Anzeige ermöglicht.

  • MPC-Gruppe
    • Block-Link = Verweis auf den zugehörigen Block
    • Melder-Link = Verweis auf den zugehörigen Belegtmelder. Mögliche Werte sind die Melder-Nummer:
      - Bei 0 ist die Anzeige nur mit dem Block gekoppelt;
      - Bei -1 wird die Anzeige über eine Fahrstrasse gesteuert, dann muss das Gleis im Fahrstrassenformular angegeben werden.
      - Ist ein Belegmelder eingetragen, muss das Gleis im Fahrstrassenformular eingegeben werden.
  • ESTW-Gruppe
    • Lupe/Berü = Das Element wird auf der entsprechenden Seite gezeichnet
    • Position X = Beginn des Gleiselementes (linke Seite) auf dem Bild
    • Position Y1 = Höhenmitte von Abschnitt 1 auf dem Bild
    • Position Y2 = Höhenmitte von Abschnitt 2 (wenn vorhanden) auf dem Bild
    • Länge = Länge des Teilabschnitt (wenn vorhanden) (Pixel)
    • Länge total = Länge des Gleiselemente (Pixel)
    • Typ = Art des Elementes (siehe unten)
    • Bereich = Zugehörige Bahnhof-Nummer
    • Gleis-Bez = Gleisnummer oder andere Bezeichnung (Text)
  • Blaue Felder werden vom Programm genutzt
    • Index = Fortlaufende Nummer, wird automatisch gesetzt
    • Status = frei (kein Bit), belegt (Bit 1), Fahrstrasse (Bit 2), Rangierstrasse (Bit 3)
    • VsM = Verschlussmelder: Der Block ist in eine aktive Fahrstrasse eingebunden

Es gibt für diese Gleise die folgenden Typen:

  • Typ 0: Gerades Gleis ohne Text mit Link zur Belegtmeldung
  • Typ 1: Gerades Gleis mit Text mit Link zur Belegtmeldung
  • Typ 2: Gerades Gleis ohne Text mit Link zur Belegtmeldung mit Spitze
  • Typ 3: Gerades Gleis mit Text mit Link zur Belegtmeldung mit Spitze
  • Typ 4: Gleissprung ohne Text mit Link zur Belegtmeldung
  • Typ 5: Gleissprung mit Text mit Link zur Belegtmeldung
  • Typ 6: Gleisverbindung links, schräg, senkrecht
  • Typ 7: Gleisverbindung rechts, schräg, senkrecht
  • Typ 8: Gerades Gleis, Dummy weiss

Position und Länge können mit den Cursortasten verändert werden, wenn diese Option auf der Configseite aktiviert ist. Die Werte in den zugehörigen Feldern zählen jeweils um 1 Pixel rauf oder runter.

Lupe:

Berü:

Gleise neu anlegen

Wichtig: Bevor der Schalter "Neu" betätigt wird müssen in die Felder Lupe und Berü die richten Werte eingetragen sein. Aus Bereich und Signal-Bez. bildet das Programm einen eindeutigen Schlüssel (Key). Auf Lupe und Berü wird gezeichnet, dafür wird vom Programm jeweils ein Objekt erzeugt.
Änderungen dieser Felder werden vom Programm zur Laufzeit zwar angenommen, aber erst nach einem Neustart umgesetzt (Daten sichern nicht vergessen).

Bearbeitet am 14.05.2015


Weichen

Konfiguration - Weichenseite

Weichen - Eingabetabelle

Auf diesem Formular werden die Daten für alle Arten von Weichen, Kreuzungen und Kreuzungsweichen eingegeben. Es können maximal 1 bis 256 Weichen eingetragen werden, der Index ist die Nummer des zugehörigen Objektes auf dem Bildschirm.

Über den Schalter „Details“ kann man die Schaltzeiten der Weichen individuell pro Karte einstellen, hinzugefügt für Motorweichen.

  • MPC-Bereich
    • Weiche-Num = Nummer der Weiche gemäß MPC-Steuerung.
    • Block (Kreuz) = Nummer des zugehörigen Block, bei Kreuzungen der kreuzende Block
      oder bei DWK der Link auf die Weiche mit Antrieb
    • Melder (Kreuz) = Nummer des zugehörigen Melders, bei Kreuzungen der kreuzende Melder
      oder bei DWK der Link auf die Weiche ohne Antrieb
    • Led Lage rechts = Ledanzeige für Fahrstrasse und Belegtmeldung der Weichenlage
    • Led Lage links = Ledanzeige für Fahrstrasse und Belegtmeldung der Weichenlage
    • Led Gleis rechts = Ledanzeige für Fahrstrasse und Belegtmeldung der Gleise
    • Led Gleis links = Ledanzeige für Fahrstrasse und Belegtmeldung der Gleise
    • Led Spitze = Ledanzeige für Spitze der Weiche - in Sonderfällen notwendig.
    • WSpM = Led Weichensperrmelder
    • WVrM = Led Weichenverriegelungsmelder
    • WGT = Weichengruppentaster
    • WT re/li = Weichentaster rechts/links
    • Anschlüsse vertauscht = Elektrische Anschlüsse sind vertauscht
    • Mittelweiche = Mittelweiche (gibt es nur in speziellen Situationen, siehe Handbuch)
  • ESTW-Bereich
    • Lupe/Berü = Das Element wird auf der entsprechenden Seite gezeichnet
    • Position X = Begin des Gleiselementes (Verriegelungsmelder) auf dem Bild
    • Position Y = Höhenmitte des Verriegelungsmelders auf dem Bild
    • Abstand = Gleisabstand (abhängig vom Typ)
    • Länge Spitze = Länge der Weichenspitze (Gleis)
    • Länge Gerade = Länge des geraden Schenkel
    • Länge Abzw. = Länge des abzweigenden Schenkel
    • Typ = Art der Weiche auf dem Bildschirm
    • Bereich = Zugehörige Bahnhof-Nummer
    • Weichen-Bez = Weichennummer oder andere Bezeichnung (Text)
  • Blaue Felder werden vom Programm genutzt.
    • Index = Nummer des zugehörigen Bildschirmobjektes (automatisch)
    • Status = frei (kein Bit), belegt (Bit 1), Fahrstrasse (Bit 2), Rangierstrasse (Bit 3)
    • Lage links = Weiche befindet sich in Stellung Links
    • Liegt = Weichenstellung ist dem Programm bekannt
    • Weiche gesperrt = Weiche ist gegen Umstellen gesperrt
    • FstAkt = Weiche liegt im Fahrweg einer aktuellen Fahrstrasse
    • Weiche verriegelt = Zähler, wie oft eine Verriegelung angefordert wurde
    • Flankenschutz = Zähler, wie oft die Weiche Flankenschutz gibt.

Position, Abstand und Länge können mit den Cursortasten verändert werden, wenn diese Option auf der Configseite aktiviert ist. Die Werte in den zugehörigen Feldern zählen jeweils um 1 Pixel rauf oder runter.

Der Abstand der Weichenabgänge kann nun für die Typen 0-3 und 10-13 bis auf den Faktor 10 eingestellt werden. 0 ist als halber Gleisabstand vorgesehen für eine Gleisverbindung und Weichen in Schräglage der Typen 4-7. Die Typen 4-7 kennen nur den Abstand 1, 2 und 3.

Hier mal verschiedene Beispiele für die Typen und Zustände:

In der oberen Reihe sind die möglichen Weichentypen dargestellt, die Nummer ist gleich der Typ. Bei Weiche 0 ist die Stellung nicht definiert (Liegt nicht gesetzt). In der Reihe darunter ist Nr.11 eine Weiche vom Typ 1 mit Abstand 0. Weiche 15 und Kreuzung 14 haben Abstand 2.

Für die weiteren Weichen gilt: 21 = gesperrt; 22 = Fahrstrasse; 23 = Fahrstrasse und Weiche verriegelt; 24 = Weiche verriegelt, gibt Flankenschutz; 25 = Weiche belegt und verriegelt.

Weichen neu anlegen

Wichtig: Bevor der Schalter "Neu" betätigt wird müssen in die Felder Lupe und Berü die richten Werte eingetragen sein. Aus Bereich und Signal-Bez. bildet das Programm einen eindeutigen Schlüssel (Key). Auf Lupe und Berü wird gezeichnet, dafür wird vom Programm jeweils ein Objekt erzeugt.
Änderungen dieser Felder werden vom Programm zur Laufzeit zwar angenommen, aber erst nach einem Neustart umgesetzt (Daten sichern nicht vergessen).

Bearbeitet am 14.05.2015


Melder

Konfiguration - Melderseite

Belegtmelder - Eingabetabelle

Die Liste der Belegtmelder wird automatisch angelegt, wenn auf der Config-Seite Belegtmelder eingestellt wurden. Es gibt nur wenige Einstellungen:

  • MPC-Gruppe
    • Melder-Num = MPC-Nummer des Belegtmelders
    • Led an = Nummer der Led, die eingeschaltet werden soll
    • Led aus = Nummer der Led, die ausgeschaltet werden soll
  • Blaue Felder werden vom Programm genutzt
    • Belegt = Markiert wenn eine Belegtmeldung vorliegt
Bearbeitet am 22.07.2007


Signale

Konfiguration - Signalseite

Signale - Eingabetabelle

Mit Signalen sind nicht nur die Licht- und Formsignale gemeint, sondern auch Start- und Zielpfeile ohne Signal. Alle Start- und Zielpunkte für Zugfahrten müssen an einem "Signal" beginnen und an einem "Signal" enden. Ein Signal gehört immer zu einem Block Es gibt unterschiedliche Typen von Signalen:

  • Typ 0: Hauptsperrsignal mit Zs1, Zs7 und Kennlicht
  • Typ 1: Ausfahrsignal mit Zs1, Zs7 und Kennlicht
  • Typ 2: Einfahrsignal mit Zs1, Zs7 und Kennlicht
  • Typ 3: Blocksignal einfach
  • Typ 4: Sperrsignal mit Zugstrassenziel
  • Typ 5: Sperrsignal
  • Typ 6: Zugstrassenstart/Ziel ohne Signal
  • Typ 7: Zugstrassenziel ohne Signal (auch Rangierstrassenziel)
  • Typ 8: Rangierstrassenstart/Ziel ohne Signal
  • Typ 9: Alleinstehendes Vorsignal

Bedeutung der Felder:

  • MPC-Bereich
    • Block = Zugehöriger Block
    • Taster = Taster im Stellpult
    • Hp0 = Led für Lichtsignal und im Stellpult, Magnetspule vom Formsignal
    • Hp1 = Led für Lichtsignal und im Stellpult, Magnetspule vom Formsignal
    • Hp2 = Led für Lichtsignal und im Stellpult, Magnetspule vom Formsignal
    • Sh0 = Led für Lichtsignal und im Stellpult, Magnetspule vom Formsignal
    • Sh1 = Led für Lichtsignal und im Stellpult, Magnetspule vom Formsignal
    • Vors. mit Hp Gekoppelt = Schalter bewirkt eine direkte Verbindung zwischen alleinstehendem Vorsignal und Hauptsignal.
    • Vr li ob = Led für Lichtsignal und im Stellpult Vr0, Magnetspule vom Formsignal Vr0
    • Vr re ob = Led für Lichtsignal und im Stellpult Vr1/2, Magnetspule vom Formsignal Vr1
    • Vr li un = Led für Lichtsignal, Magnetspule vom Formsignal Vr2
    • Vr re un = Led für Lichtsignal
    • Link = Nummer des Vorsignals oder Hauptsignals, an dessen Standort sich das Vorsignal befindet (am gleichen Mast)
    • SBET/SBRT = Selbststellbetrieb ein- und ausschalten
    • FüM = Led Fahrstrassenüberwachungsmelder
    • SB-Auto = Led Selbststellbetrieb ein
    • Signalsperrmelder = Led dafür
  • ESTW-Bereich
    • Bereich = Zugehörige Bahnhof-Nummer
    • Signal-Bez. = Signalbezeichnung
    • Lupe/Berü = Das Element wird auf der entsprechenden Seite gezeichnet
    • Position X = Beginn des Gleiselementes (Verriegelungsmelder) auf dem Bild
    • Position Y = Höhenmitte des Verriegelungsmelders auf dem Bild
    • Länge = Länge des Gleisabschnitts
    • Richt./Typ = Fahrtrichtung rechts/ links; Typ
    • VrAH = Vorsignal am Hauptsignal = 1
      für Pfeile gilt: 0 kein Text, sonst Text rot, gelb, weiss (1,2,3)
    • FstAuto = Index der Fahrstrasse bei Selbststellbetrieb
    • B = Block mit Nr. schaltet die Fahrstrasse
    • HB = Hilfsblock mit Nr. schaltet die Fahrstrasse
    • M = Melder mit Nr. schaltet die Fahrstrasse
  • Blaue Felder werden vom Programm genutzt.
    • Index = Nummer des zugehörigen Bildschirmobjektes (automatisch)
    • Status = frei (kein Bit), belegt (Bit 1), Fahrstrasse (Bit 2), Rangierstrasse (Bit 3)
    • Stellung = Signalstellung und Vorsignalstellung
    • SB-Akt. = kein (0), möglich (1), eingeschaltet (2)
    • Zs1M = Zusatzsignal vorgesehen, aber für spätere Versionen
    • Zs7M = Zusatzsignal vorgesehen, aber für spätere Versionen
    • FüM = Fahrstrassenüberwachungsmelder ein
    • Blk = FüM blinkt
    • SSpM = Signalsperrmelder ein
    • markiert = Signal ist markiert
    • FstZiel = Ziel einer aktiven Fahrstrasse
    • FstStart = Start einer aktiven Fahrstrasse

Position und Länge können mit den Cursortasten verändert werden, wenn diese Option auf der Configseite aktiviert ist. Die Werte in den zugehörigen Feldern zählen jeweils um 1 Pixel rauf oder runter.

Hier Beispiele für die Darstellung der Signale auf der Lupe:

In der oberen Reihe sind die verschiedenen möglichen Zustände eines Hauptsignals gezeigt: von links nach rechts Hp0, Hp1/2, Kennlicht, Sh1, Zs1, Zs7, Selbststellbetrieb, Fahrstrasse und FüM, Signal gesperrt. Darunter stehen die möglichen Typen von 1 bis 8.

Die gleiche Darstellung auf der Berü:

  • Bei den Werten (Stellungen) gilt
    • Wert 0: Halt (Hp0, Sh0)
    • Wert 1: Fahrt (Hp1, Hp2)
    • Wert 2: Kennlicht
    • Wert 3: Rangierfahrt (Sh1)
  • Bei den Typen 1-3 gibt es Selbststellbetrieb
  • Die Objekte stehen jeweils
    • Richt 0: rechts unten oder
    • Richt 1: links oben
  • Bei Zugstrassenpfeilen Typ 7 (grün) gilt
    • Richt 0: rechts oben, Fahrtrichtung rechts (Ziel)
    • Richt 1: links oben, Fahrtrichtung links (Ziel)
  • Bei Rangierpfeilen Typ 8 (blau) gilt
    • Richt 0: rechts oben, Fahrtrichtung rechts (Ziel)
    • Richt 1: links oben, Fahrtrichtung links (Ziel)
    • Richt 2: rechts oben, Fahrtrichtung rechts (Start)
    • Richt 3: links oben, Fahrtrichtung links (Start)
    • Richt 4: beide oben, Fahrtrichtung rechts (Ziel re, Start li)
    • Richt 5: beide oben, Fahrtrichtung links (Ziel li, Start re)
    • Richt 6: rechts oben, Fahrtrichtung rechts (Ziel und Start)
    • Richt 7: links oben, Fahrtrichtung links (Ziel und Start)
    • Richt 8: beide oben, Fahrtrichtung beide (Ziel und Start)

Signal anlegen

Wichtig: Bevor der Schalter "Neu" betätigt wird müssen in die Felder Bereich, Signal-Bez., Lupe und Berü die richten Werte eingetragen sein. Aus Bereich und Signal-Bez. bildet das Programm einen eindeutigen Schlüssel (Key). Auf Lupe und Berü wird gezeichnet, dafür wird vom Programm jeweils ein Objekt erzeugt.
Änderungen dieser Felder werden vom Programm zur Laufzeit zwar angenommen, aber erst nach einem Neustart umgesetzt (Daten sichern nicht vergessen).

Neu am 14.05.2015


Fahrstrassen

Konfiguration - Fahrstrassenseite

Fahrstrassen - Eingabetabelle

Fahrstrassen sind das wesentliche bei dieser Steuerung, alle Zugbewegungen erfolgen anhand von Fahrstrassen. Es gibt zwei Arten Zugstrassen (grün angezeigt) und Rangierstrassen (blau angezeigt). Für Zugstrassen sind die Bedingungen sehr viel strenger als für Rangierstrassen. Die Felder haben folgende Bedeutung:

  • MPC-Bereich und ESTW-Bereich
    • Kennung = Start- und Ziel-Signal getrennt durch einen Punkt bei Fahrstrassen, getrennt durch einen Bindestrich bei Rangierstrassen (z.B. 12N1.15N2). Diese Bezeichnung muss eindeutig sein.
    • Index = wird vom Programm vergeben
    • von Block = Startblock der Fahrstrasse
    • nach Block = Zielblock der Fahrstrasse
    • Signalbild Hp = angezeigtes Signalbild Hp1 oder Hp2 (Wert 1 oder 2), bei Wert -1 bleibt das Startsignal auf Hp0/Sh0 (für Mittelweichen und Lokumsetzen in Kopfbahnhöfen)
    • Rangierstrasse = 1, wenn eine Rangierstrasse; in Sonderfällen auch 2 (siehe Handbuch)
    • Richtung MPC = Strombezogene Fahrtrichtung vorwärts (1) oder rückwärts (2)
    • Taster 1/2 = Taster im Stellpult, falls vorhanden
    • BM frei 1/2 = analog MPC (zusätzliche Auflösebedingung)
    • BM bes v/r = analog MPC (zusätzliche Auflösebedingung)
    • Sig Start/Ziel = Index des Signals am Start- und am Zielpunkt; das sind wichtige Felder für die korrekte Funktion des Programms. Am Ziel steht bei Zugstrassen das Signal, an dem der Zug anhält, das ist nicht immer das "Signal" (der Richtungspfeil) aus der Kennung. (Beispiel. 12N2.12NGr, das Ziel ist nicht der Pfeil NGr sondern das Signal 12B)
    • Trennstelle = Nummer der Trennstelle, die Überfahren wird.
    • Ri.w. = Blocknummer, bei dem erstmalig die Fahrtrichtung gewechselt wird.
    • Eingl. Strecke = Nummer der eingleisigen Strecke
    • Anrückmeld. für BÜ = Bahnübergang, der nicht öffnen soll, wenn diese Fahrstrasse gestellt wird.
    • Über-Blöcke = alle Gleise zwischen Start und Ziel in der Reihenfolge, wie sie überfahren werden: unter Num steht die Nummer oder der Index je nach Typ, unter Bes. steht immer eine Null (wird vom Programm genutzt)
      • B = Hauptblock
      • H = Hilfsblock
      • P = Pseudoblock (Block ohne Hardware)
      • G = Gleisabschnitt (Index) außer bei Link zum Start- oder Zielblock
      • U = Bahnübergang (Index)
    • Weichen = die Weichen, die umgestellt werden sollen; Nummer und "L" oder "R" für Weichen im Fahrweg, für Weichen, die Flankenschutz geben "l" oder "r".
    • Led = Led's, die zusätzlich eingeschaltet werden sollen
    • S = Vorsignal, das mit dem Startsignal geschaltet werden soll
    • ü = Vorsignal, das mit einem Zwischensignal geschaltet werden soll
    • Z = Vorsignal, das mit dem Zielsignal geschaltet werden soll
  • Blaue Felder werden vom Programm genutzt.
    • Besitzer der Fst. = Fahrregler, der die Fahrstrasse besitzt.
    • Fahrstrasse aktiv = Die Fahrstrasse ist geschaltet.

Fahrstrasse anlegen

Wichtig: Bevor der Schalter "Neu" betätigt wird muss in das Feld Kennung der richte Wert eingetragen sein. Die Kennung ist ein eindeutiger Schlüssel (Key).
Eine Änderung dieses Feldes wird vom Programm zur Laufzeit zwar angenommen, aber erst nach einem Neustart umgesetzt (Daten sichern nicht vergessen).

Sonstiges

Die Felder Sig. Start/Ziel können auch per Doppelklick gefüllt werden.

Überarbeitet am 14.05.2015


Strecken

Konfiguration - BÜ-Seite

Bahnübergänge - Eingabetabelle

Der Bereich Bahnübergänge befindet ist fertig (kann künftig noch erweitert werden), hier funktionieren die die Anzeige des Status, manuelles Öffnen und Schliessen, Dauereinschaltung und Automatik, Ein- Aus-Tasten.
Die Felder haben die folgende Bedeutung:

  • MPC-Bereich
    • Block = Verweis auf den zugehörigen Block
    • Melder = Verweis auf den zugehörigen Melder
    • BÜ-Taste = Bahnübergangstaste im Stellpult
    • Anschalt-Led = Nummer einer Led der MPC (oder 0)
    • Dauerein.-Led = Nummer einer Led der MPC (oder 0)
    • Vorsicht-Led = Nummer einer Led der MPC (oder 0)
    • Frei/Auto-Led = Nummer einer Led der MPC (oder 0)
    • HFM/Err.-Led = Nummer einer Led der MPC (oder 0)
    • über Led = Ansteuerung über Led-Ausgänge
    • Weiche r/l = Ansteuerung mit Impuls über Weichenkarte
    • Spule = Ansteuerung mit Impuls über Formsignalkarte
    • Anrück = Anrückmelderpunkt (verhindert vorzeitiges Öffnen)
    • Zu = Melder, der den Schließvorgang auslöst
    • Auf = Melder, der ein Öffnen erlaubt
  • ESTW-Bereich
    • Lupe/Berü = Das Element wird auf der entsprechenden Seite gezeichnet
    • Position X = Beginn des Gleiselementes (linke Seite) auf dem Bild
    • Position Y = Höhenmitte von Abschnitt 1 auf dem Bild
    • Länge = Länge des Gleiselementes (Pixel)
    • Mitte = Abstand bis zur Mitte von links
    • Typ = Art des Elementes (siehe unten)
    • Master = für mehrgleisige Bahnübergänge
    • Öffnungszeit (mind.) = Mindestöffnungszeit für den Bahnübergang - später
    • Bereich = Zugehörige Bahnhof-Nummer
    • Bezeichnung = Nummer oder andere Bezeichnung (Text)
    • km = Gleis-km, wird auf dem Bildschirm angezeigt
  • Blaue Felder werden vom Programm genutzt
    • Index = Fortlaufende Nummer, wird automatisch gesetzt
    • Status = frei (kein Bit), belegt (Bit 1), Fahrstrasse (Bit 2), Rangierstrasse (Bit 3)
    • Sicher = gesichert
    • Dauereinsch. = Bahnübergang ist ständig geschlossen (z.B. Anrufschranke)
    • Autom. Sperre = Bahnübergang wird zugbewirkt geschaltet
    • Blink = Merker, dass die Led blinken soll
    • Anrückmelder = Zähler für kommende Züge

Position, Mitte und Länge können mit den Cursortasten verändert werden, wenn diese Option auf der Configseite aktiviert ist. Die Werte in den zugehörigen Feldern zählen jeweils um 1 Pixel rauf oder runter.

Es gibt die folgenden Typen:

  • Bit: 0000 0000 = Beschrankter Bahnübergang eingleisig
  • Bit: 0000 0001 = Unbeschr., Halbschr., Signalisiert (1)
  • Bit: 0000 0010 = mehrgleisig oben (2)
  • Bit: 0000 0100 = mehrgleisig mitte (4)
  • Bit: 0000 1000 = mehrgleisig unten (8)
  • Bit: 0001 0000 = FÜ rechts (16)
  • Bit: 0010 0000 = FÜ links (32)
  • Bit: 1100 0000 = frei (64) (128)

Beispiele für Bahnübergänge

Ansicht auf der Lupe

Auf den Bildern sind jeweils die folgende Bahnübergänge abgebildet:

    • 1 BÜ über 3 Gleise, geöffnet
    • 2 BÜ über 3 Gleise, geschlossen Fahrstrasse auf Gleis 3
    • 3A BÜ einfach, Rangierstrasse angefordert, BÜ noch offen
    • 3B BÜ einfach, Rangierstrasse, BÜ geschlossen
    • 3C BÜ einfach, auf Dauer geschlossen
    • 3D BÜ einfach, auf Dauer geschlossen, Automatik abgeschaltet (Anrufschranke)
    • 3E BÜ einfach, Automatik abgeschaltet
    • 4 BÜ mit Halbschranke oder Lichtanlage (aus)
    • 5 BÜ einfach, Fernüberwacht von rechts
    • 6 BÜ einfach, Fernüberwacht, geschlossen und belegt

Ansicht auf der Berü

Bahnübergang neu anlegen

Wichtig: Bevor der Schalter "Neu" betätigt wird müssen in die Felder Lupe, Berü, Bereich und Bezeichnung die richten Werte eingetragen sein. Aus Bereich und Bezeichnung bildet das Programm einen eindeutigen Schlüssel (Key). Auf Lupe und Berü wird gezeichnet, dafür wird vom Programm jeweils ein Objekt erzeugt.
Änderungen dieser Felder werden vom Programm zur Laufzeit zwar angenommen, aber erst nach einem Neustart umgesetzt (Daten sichern nicht vergessen).

Bearbeitet am 14.05.2015


Zuege

Konfiguration - Zugseite

Fahrzeuge/Züge - Eingabetabelle

Auf dieser Seite stehen ähnliche Angaben wie bei der MPC-Steuerung und eine Reihe von Werten, die vom Programm benötigt werden (blaue Felder)

Während des Fahrbetriebes können die blauen Felder nicht verändert werden, auch neue Züge dürfen nicht angelegt werden: Die Tasten "Neu" und "Übernehmen" sind gesperrt. Es können aber die Eigenschaften des Zuges geändert werden. Zur Übernahme der Werte auf den Haken drücken.

Der Geschwindigkeitsbereich reicht abweichend von der MpC von 0 – 120. Die Hardware kann zwar nur 16 Fahrstufen, aber durch geeignete Modulation ergeben sich mehr Fahrstufen. Der Regelbereich wird auch in diesem Programm anhand einer nicht linearen Kurve angepasst.

Hier eine kurze Beschreibung der wesentlichen Eingaben:

    • Lok-Nr. zwischen 1 und 400
    • Name = beliebiger Text (16 Stellen)
    • Zug-Nummer (Fahrpl.) = beliebiger Text (6 Stellen)
    • klassische Fahrplan-Nummern für Zugleitsystem (später vorgesehen)
    • a = Beschleunigung (1-30)
    • b = Verzögerung (1-30)
    • c = Verzögerung im Bremspunkt (0-20)
    • sch = Schleichgeschwindigkeit (10-90) %-Wert von max-min
    • hp2 = Hp2-Geschwindigkeit (30-99) %-Wert von max-min
    • hp3 = Hp3-Geschwindigkeit (30-99) %-Wert von max-min
    • min = kleinste Geschwindigkeit (0-50)
    • max = größte Geschwindigkeit (30-120)
    • KU = Kurzzug

Unter Vorzugsgleise können bevorzugte Fahrstrassen je Zug eingestellt werden, z.B. im Bahnhof sollen Regionalzüge auf Gleis 1 und Fernzüge auf Gleis 2 einfahren. Vorausetzung ist Selbststellbetrieb, es werden das auslösende Signal (Index) und die Fahrstrasse (Index) eingegeben.

Alle blauen Felder werden intern vom Programm genutzt: Das sind die aktuelle Position, Geschwindigkeiten, Richtung, Bremspunkte, Haltepunkte, Modi, Fahrstrassen, zu befahrende Blöcke, Korrekturen, Fahrplan und ggf. eingestellte Route.

Im Programm sind bereits 400 Züge (Fahrregler) voreingestellt, mit „Neu“ wird wie bei den Blöcken ein Fahrregler für die Nutzung eingerichtet. (Details siehe Handbuch)

Bearbeitet am 14.05.2015


Sonstiges

Konfiguration - Sonstigesseite

Sonstiges (Texte, Prellböcke, Bahnsteige, Pfeile) - Eingabeformular

Auf dem Formular werden Objekte angegeben, die mit Ausnahme Typ 0 und 6 für die Funktion des Programms ohne Bedeutung sind. Diese Objekte dienen lediglich der "Ausschmückung" der Bildschirmdarstellungen. Der Bahnhofstitel besitzt ein funktionstüchtiges Menü für verschiedene Befehle. Es gibt folgende Typen:

  • 0: Bahnhofstext mit Nummer und Menü
  • 1: Einfacher Text, im Feld Höhe steht die Schriftgröße
    • Länge = 0: Text wird nicht angezeigt
    • Länge = 1: Text fett
    • Länge = 2: Text kursiv
    • Länge = 3: Text fett, kursiv
    • Länge = 4: Text unterstrichen
    • Länge = 5: Text einfach
  • 2: Bahnsteig Höhe = 1 - 3
  • 3: Prellbock
  • 4: Sprung bzw. Versatz, Bez2 = Lupentext, Bez3 = Berü-Text
    • Höhe = 1 für Anzeigen
    • Höhe = 2 für Anzeigen Pfeil rechts mit Text
    • Höhe = 3 für Anzeigen Pfeil links mit Text
  • 5: MPC-Fahrtrichtung (Hinweis-Pfeil)
  • 6: Entkuppler (nur auf der Lupe angezeigt, Beru = 0)
    • Länge = 0: wird vom Programm genutzt
    • T1/T2 = Tastenkombination für den Entkuppler
    • Led = Ledausgang über den der Entkuppler mittels Minirelais geschaltet wird
    • T = Schaltzeit

Position und Länge können mit den Cursortasten verändert werden, wenn diese Option auf der Configseite aktiviert ist. Die Werte in den zugehörigen Feldern zählen jeweils um 1 Pixel rauf oder runter.

Sonstiges neu anlegen

Wichtig: Bevor der Schalter "Neu" betätigt wird müssen in die Felder Lupe und Berü die richten Werte eingetragen sein. Aus Bereich, Key-Text und Typ bildet das Programm einen eindeutigen Schlüssel (Key). Auf Lupe und Berü wird gezeichnet, dafür wird vom Programm jeweils ein Objekt erzeugt.
Änderungen dieser Felder werden vom Programm zur Laufzeit zwar angenommen, aber erst nach einem Neustart umgesetzt (Daten sichern nicht vergessen).

Zugspeicher

Der Zugspeicher ist eine Einrichtung speziell auf die Bedürfnisse einer Modellbahn mit vielen Fahrzeugen abgestimmt. Im Zugspeicher stehen alle Loks, die deaktiviert sind. Durch einfaches Anklicken können diese Loks in die Anzeige übernommen werden. Auf dieser Seite stehen die Daten für die Position einer Liste auf der Lupe (oder der Berü).

Paternoster

Die Fahrstrassen zum und aus Paternostergleisen können nun durch Eingabe der Nummer am 10er-Block des Stellpultes geschaltet werden (Gleicher Befehl wie Zugauswahl), Nummern 456-599 Das Programm schaltet eine Ausfahrstrasse, wenn im Paternoster ein Zug steht, sonst die Einfahrstrasse. Hier werden die Bereichkennung und die Signale eingetragen, das Programm kombiniert daraus den zugehörigen Fahrstrassenbefehl: z.B. 30PA.30501 (Signal.Gleis) oder 30501.30PE (Gleis.Signal).

Überarbeitet am 14.05.2015


Strecken

Konfiguration - Streckenseite

Eingleisige Strecken - Eingabetabelle

In diesem Programmteil sind nur grundlegende Funktionen für den Bedarf der Modellbahn implementiert. Es gibt maximal 16 eingleisige Strecken.

Eine eingleisige Strecke muss nur eingerichtet sein, wenn diese lang genug ist, das Züge von beiden Richtungen in diese Strecke einfahren können und keine Ausweichmöglichkeit besteht. Wenn eine eingleisige Strecke von einem Zug belegt ist, wird die gesamte Strecke für die Entgegengesetzte Fahrtrichtung gesperrt. Es können mehrere Züge hintereinander eine Strecke befahren, vorausgesetzt es gibt genügend Blöcke. Im ESTW heißt das Ganze "Erlaubnis abgeben" (EA). Mit einer Erlaubnisabgabe wird die Fahrtrichtung gewechselt.

Die Bedeutung der Felder ist wie folgt:

  • MPC-Bereich
    • Str.-Num = Nummer der eingleisigen Strecke
    • Taster vorw. = Umschalten auf Fahrtrichtung vorwärts
    • Taster rückw. = Umschalten auf Fahrtrichtung rückwärts
    • Led vorw. = Anzeige im Stellpult, Vorwärts eingeschaltet
    • Led rückw. = Anzeige im Stellpult, Rückwärts eingeschaltet
    • Led Sperrmel. = Anzeige im Stellpult, Rückwärts eingeschaltet
    • Block = Alle Blöcke, die zur Strecke gehören
    • Richt. = noch offen
  • ESTW-Bereich
    • Index = Nummer der Objektes auf der Lupe und Berü
    • Lupe/Berü = Das Element wird auf der entsprechenden Seite gezeichnet
    • Position X = Beginn des Gleiselementes (linke Seite) auf dem Bild
    • Position Y = Höhenmitte auf dem Bild
    • Invert = MPC-Fahrtrichtung vorwärts von rechts nach links
    • Bereich = Zugehörige Bahnhof-Nummer
    • Strecke Bez. = Eindeutige Bezeichnung der Strecke (Key)
  • Blaue Felder werden vom Programm genutzt
    • Richtung = bezeichnet die aktuelle eingestellte Fahrtrichtung:
      • 0 = vorwärts eingestellt, Symbol gelb
      • 1 = rückwärts eingestellt, Symbol gelb
      • 2 = vorwärts eingestellt, festgelegt Symbol rot
      • 3 = rückwärts eingestellt, festgelegt Symbol rot

Darstellung der Eingleisigen Strecke auf Lupe und Berü. Wenn die Strecke belegt ist wechselt die Farbe auf rot, dann kann die Richtung nicht gewechselt werden.

Eingleisige Strecke neu anlegen

Wichtig: Bevor der Schalter "Neu" betätigt wird müssen in die Felder Lupe, Berü und Strecke-Bez die richten Werte eingetragen sein. Auf Lupe und Berü wird gezeichnet, dafür wird vom Programm jeweils ein Objekt erzeugt.
Änderungen dieser Felder werden vom Programm zur Laufzeit zwar angenommen, aber erst nach einem Neustart umgesetzt (Daten sichern nicht vergessen).

Bearbeitet am 14.05.2015


Melder

Konfiguration - Melderseite

Trennstellen - Eingabetabelle

Es gibt analog zur MPC drei Typen von Trennstellen, ohne Wechsel der Polung (0), mit Wechsel der Polung und diese jeweils vorwärts (1) und rückwärts (2). Das bedeutet die MPC-bezogene Fahrtrichtung läuft auf die Trennstelle zu (vorwärts) oder von der Trennstelle weg (rückwärts). Die Eingaben haben die folgende Bedeutung:

  • MPC-Gruppe
    • Trennst.-Num = Nummer der Trennstelle
    • von Block = Blocknummer vor der Trennstelle
    • nach Block = Blocknummer hinter der Trennstelle
    • Typ = 0 ohne Polwechsel 1 und 2 mit Polwechsel v/r
  • ESTW-Gruppe
    • Lupe = Das Element wird auf der entsprechenden Seite gezeichnet
    • Position X = Position auf der Lupe
    • Position Y = Position auf der Lupe
  • Blaue Felder werden vom Programm genutzt
    • Status = 0 = grün (befahrbar), 1 = gelb (bereit Typ 0), 2 = rot (gesperrt)

Die Position kann mit den Cursortasten verändert werden, wenn diese Option auf der Configseite aktiviert ist. Die Werte in den zugehörigen Feldern zählen jeweils um 1 Pixel rauf oder runter.

Bearbeitet am 25.09.2007


Extras

Konfiguration - Taster

Taster - Eingabetabellen und Übersicht

Sondertasten

Sondertasten müssen manuell angelegt werden, dazu die Taste "+" drücken, dann wird eine neue Zeile angelegt. Es müssen die Bezeichnung und eine gültige Tasternummer eingetragen werden. Der Datensatz wird mit "Übernehmen" in die Daten übernommen. Mit der Taste '-' kann eine Zeile entfernt werden. Es sind bisher die folgenden Sondertasten im Programm definiert:

Code | Bezeichnung | Stand
Bhf | Bahnhoftaste | man.
NE | Nachteinschaltung | später
TE | Tageinschaltung | später
SGT | Signalgruppentaster | autom.
SSpT | Signalsperrtaste | autom.
SESpT | Signalentsperrtaste | autom.
WGT | Weichengruppentaster | autom.
WSpT | Weichensperrtaste | autom.
WESpT | Weichenentsperrtaste | autom.
FRT | Fahrstrassenrücknahmetaste | man.
FHT | Fahrstrassenhilfstaste | man.
UFGT | Umfahrstrassengruppentaste | man.
MGT | Sonderfunktionen | man.
DET | Dauereinschalttaste (BÜ) | autom.
DELT | Dauereinschaltlöschtaste (BÜ) | autom.
AufT | Öffnentaste (BÜ) | autom.
ZuT | Schliessentaste (BÜ) | autom.
STein | Stellstisch ein | man.
STaus | Stelltisch aus | man.

Tastenbefehle

Diese Tabelle wird intern vom Programm genutzt. Diese Tabelle wird automatisch gefüllt: Zum Beispiel aus dem Tableau Strassen wird der Befehl für das Auslösen der Fahrstrassen extrahiert. Aus dem Weichentableau werden die Kombinationen für die Schalt- und Sperrbefehle erstellt, dafür muss der Tastencode entsprechend der oberen Tabelle existieren. Weitere Befehle werden aus den anderen Tableaus generiert.

Fast alle Tastenkombinationen werden vom Programm automatisch erstellt, wenn auf den entsprechenden Seiten der "Übernahme"-Schalter aktiviert wird. Für Ausnahmefälle ist es auch möglich, manuelle Eingaben vorzunehmen, wichtig ist: Der Schlüssel muss 8-Stellig sein und der Wert muß ein existierender Tastaturbefehl sein.

Schalter

Alle Schalter müssen in der Tabelle eingetragen sein, weil eingeschaltete Schalter sonst die Tastenermittlung stören. Den Schaltern kann eine Led zugeordnet werden.

Hier können auch Softwareschalter definiert werden, die dann mit den Tastenkombinationen ein- und ausgeschaltet werden.

Bearbeitet am 14.05.2015


Fahrpult

Konfiguration - Fahrpult

Fahrpult - Eingabetabelle

Dieser Programmteil entspricht weitgehend den Feldern der MPC-Steuerung:
Die Tasten für die direkte Geschwindigkeitseingabe incl. Led funktionieren, die Stufen von 1 bis 15 teilen den Bereich zwischen min- und max-Wert in 15 Stufen auf. Taste "0" ist anhalten, Led 0 leuchtet abweichend zur MPC, wenn der Zug steht.
Die 7-Segment-Anzeige zeigt den ausgewählten Zug an. Die Auswahl erfolgt über die Blocktaste und die "*"-Taste vom 12er Block oder mit der Maus auf dem Bildschirm.
Die Tasten Generalnothalt, Einzelnothalt, Rangieren und Kurzzug sowie die Richtungstasten funktionieren ebenfalls. Auch die Tasten für die Zugeigenschaften und +/- Tasten.

Der Drehregler funktioniert auch, wenn auf der Config-Seite die Abfragezeit zu hoch eingestellt ist, ruckelt der Drehregler. Mit einem Druck auf den Drehregler wird die Sollgeschwindigkeit auf Null gesetzt.

In dieser Tabelle werden analog zur MPC Taster und Led für ein Fahrpult definiert.

Bearbeitet am 15.05.2015


Hauptmenue

Hauptmenü der Anwendung

Es existieren zwei verschiedene Menü:

  • Das Haupt-Menü der Anwendung
  • Das Menü für die Konfiguration

Neu am 23.07.2007


Das Menue der Anwendung

Das Hauptmenü der Anwendung

Datei

Die Einträge unter diesem Punkt laden oder sichern entweder alle Daten incl. der Betriebsdaten, oder nur die Daten, oder nur die Betriebsdaten (das sind die Positionen der Züge). Mit dem Punkt "Alles laden wird eine eingefrorener Betriebszustand wiederhergestellt, das ist der Normalfall.

In allen anderen Fällen werden die Betriebszustände für alle Daten in den Grundzustand versetzt. Werden erst die Daten und danach der Betriebszustand geladen, so ergibt sich ein zurückgesetzter Anlagenzustand mit frisch eingesetzten Zügen an der vorhergehenden Positionen.

Sichern und Laden direkt vereinfachen die Eingaben, es wird jeweils der letzte Dateiname benutzt.

Wenn Zuglaufpläne und Fahrplandaten mit gleichem Namen angelegt sind, werden diese auch mit dem Befehl „Alles laden“ geladen. (Für die Datensicherung gilt das nicht!)

Reset

Züge Stop führt einen Nothalt aus.

Led aus schaltet alle Led einmal aus, viele Led werden aber entsprechen der Betriebssituation sofort wieder eingeschaltet.

Led refresh, ähnlich wie Led aus, alle Anzeigen werden aufgefrischt.

Formsignale Halt schaltet alle Formsignal auf Halt, während des Stellvorgangs blinkt eine rote Alarmmeldung 'SS' (Signalstörung). Eingeführt, weil manchmal nach Betriebspausen Signale nicht mehr auf Halt stehen, warum auch immer.

Reset Hardware initialisiert die Hardware neu, dafür sollte der Betrieb abgeschaltet sein. Erforderlich, wenn das automatische Betriebsrelais durch Störungen abfällt.

Grundstellen versetzt alle Objekte in den Grundzustand, das betrifft alle internen Merker. Alle Fahrstrassen werden zurückgesetzt, alle Züge auf Stillstand uvm. Die Konfigurationsdaten bleiben alle erhalten, das Grundstellen betrifft nur die blauen (internen) Einträge.

akt. Zug bereinigen Setzt die internen blauen Felder des angewählten Zuges zurück.

Warteliste leeren Wenn eine zu volle Warteliste (flackernde Anzeige in der Meldungszeile) den Betrieb behindert, kann hier die Liste geleert werden. Die entsprechenden Befehle müssen dann neu eingegeben werden

Paternoster initialisiert die Paternostereinträge neu.

Anzeige

Hierüber können die Lupen- und Bereichsübersichten aufgerufen werden. Mit Fahrreglereinstellungen können diese Einstellungen links neben dem Fahrregler ein- oder ausgeblendet werden.

Fahrplan

Unter diesem Menüpunkt sind die Funktionen für Fahrplan / Routen zu erreichen.

Bearbeitet am 14.05.2015


Konfigurationsmenue

Das Menü der Konfiguration

Daten

Dient zum Sichern und Laden der reinen Daten.

Sonstiges

Unter diesem Menüpunkt gibt es viele wertvolle Möglichkeiten:

Verbindungen prüfen erzeugt eine Liste aller Verbindungen (oben) in Abhängigkeit vom ausgewählten Objekt. Im Bild rechts wurde beispielsweise der Block 1 abgefragt. Es können auch ein Melder, ein Signal, eine Fahrstrasse oder was Anderes abgefragt werden. Es wird immer das aktuell angezeigte Objekt analysiert.

Fehler suchen erzeugt das oben angezweigte Bild. Im angezeigten Beispiel wurde die Taste "Alles prüfen" genutzt. Man kann aber auch gezielt suchen.

Led suchen fragt zunächst nach einer Led-Nummer und zeigt ebenfalls eine Liste an.

Taster suchen fragt zunächst nach einer Taster-Nummer und zeigt ebenfalls eine Liste an.

Spule suchen fragt zunächst nach einer Magnetartikel-Nummer und zeigt ebenfalls eine Liste an.

Weichen suchen fragt zunächst nach einer Weichen-Nummer und zeigt ebenfalls eine Liste an.

Melder suchen fragt zunächst nach einer Belegtmelder-Nummer und zeigt ebenfalls eine Liste an.

Freie suchen Beinhaltet Unterpunkte, die es ermölichen bisher nicht benutzte Led, Taster und Belegmelder zu suchen.

Liste erstellen erzeugt eine Text-Datei für den entsprechenden Bereich, zum Beispiel mit allen Blöcken. In der Liste stehen die eingestellten Parameter. Zur weiteren Bearbeitung oder zur Dokumentation kann beispielsweise Excel eingesetzt werden.

Datensatz löschen löscht unter bestimmten Voraussetzungen den ausgewählten Datensatz, aber VORSICHT die Links aller nachfolgenden Datensätze müssen eventuell angepasst werden, zum Beispiel für Signale. Löschen funktioniert nur für Objekte, die selbst keine Verbindung mehr haben.

Tastertabelle löschen Löscht alle automatisch erstellte Einträge in der Tastertabelle.

Tastertabelle erstellen Erstellt alle automatisch erzeugten Einträge in der Tastertabelle neu.

Zugnummer wechseln Ermöglicht den Wechsel einer Zugnummer auf eine ungenutzte Zugnummer.

MPC-Transfer erlaubt den Austausch der Betriebsdaten mit der MPC-Steuerung. Dafür sollten die Betriebsdaten der MPC (Version 3.6) mit der Endung "bda" zunächst unter einem anderen Namen gesichert werden.

Danach kann man die Daten mit dem Schalter "MPC-Bda lesen" auswerten. Es werden alle 400 möglichen Züge in der Liste angezeigt, daneben stehen die Blöcke und die Namen der Züge. Dank der Unterstützung von Herrn Ringstmeier ist diese Funktion möglich geworden. Programm intern ist diese Funktion komplexer als sie aussieht.

Es werden nun je nach Programmsituation weitere Schalter aktiviert, damit kann der Aufenthalt der Züge im ESTW-Programm in die MPC-Daten übertragen und anschließend die Datei zurückgeschrieben werden.

Alternativ können auch die MPC-Daten in das ESTW übernommen werden. Zur Zeit nur die Position der Züge. Später sollen auch noch andere Werte nach Bedarf ausgetauscht werden. Diese Funktion steht nur zur Verfügung, wenn keine Betriebsdaten geladen sind - also nur "Daten laden" ausführen.

Bearbeitet am 15.05.2015


Popup-Menue

Popup-Menü

Viele Objekte auf den Gleisbildern eines ESTW arbeiten mit Popup-Menüs:

  • Bahnhof, das Objekt ist der Bahnhofstext
  • Hauptgleise, das sind die Blöcke der MPC
  • Bahnübergang
  • Eingl. Strecke, Erlaubnisabgaben
  • Gleise, das sind einfache Gleisverbindungen
  • Signale, da gibt es die meisten Menüs
  • Weichen

Neu am 01.07.2007


Bahnhof-Menü

Bahnhof-Menue

Lupe

In der 1. Zeile steht die Bezeichnung des Bahnhof

  • LSA = Lichtsignal ausschalten - zeigt keine Sperrsignale auf der Berü an
  • LSE = Lichtsignal einschalten - zeigt Sperrsignale auch auf der Berü an
  • LGA = Lupenbildgrenzen ausblenden - später
  • LGE = Lupenbildgrenzen anzeigen (einschalten) später
  • Andere = Zusätzliche Funktionen
    • SBA = Selbststellbetrieb ausschalten - noch nicht implementiert
    • ZLA = Zuglenkung ausschalten - später
    • NE = Nachtbetrieb einschalten - später
    • NA = Nachtbetrieb ausschalten - später

Berü

Identisch mit der Lupe

Neu am 15.07.2007


Block-Menue

Block-Menü

Lupe

In der 1. Zeile steht die Bezeichnung des Gleises

  • FPÜ = enthält ein Untermenü ohne Funktion (nur Optik)
  • ZN = Menügruppe für Zugnummern (Bezeichnungen)
    • ZN = Zugnummer anzeigen
    • EIN = Zugnummer eingeben
    • LÖE = Zugnummer löschen
  • AZG = Achszähler Grundstellen (Belegtmeldung aufheben - Grundstellen)
  • Andere = Zusätzliche Funktionen
    • FAE = Fahrstrassenelement auflösen einzeln
    • FHAE = Fahrstrassenelement hilfsweise auflösen einzeln
    • DHA = Durchrutschweg hilfsweise auflösen - nicht geplant

Berü

Das Menü für die Berü enthält weniger Punkte weil verschiedene Befehle auf der Berü nicht erlaubt sind. MA bedeutet Merkhinweise anzeigen (nicht geplant).

Bearbeitet am 02.11.2009


Bue-Menue

Bahnübergang-Menü

Lupe

In der 1. Zeile steht die Bezeichnung des Bahnübergang. Es gibt zwei Menü, eins auf jedem Gleis und eines auf der Kopfzeile.

  • UE = Bahnübergang einschalten
  • UAS = Automatisches einschalten sperren
  • UAE = Automatisches einschalten erlauben (entsperren)
  • UHF = Bahnübergang hilfsweise freimelden - nicht geplant
  • UA = Bahnübergang ausschalten
  • UHA = Bahnübergang hilfsweise ausschalten - später
  • AZG = Bahnübergang zurücksetzten (Grundstellen)
  • UDE = Bahnübergang auf Dauer einschalten
  • UDA = Bahnübergang auf Dauer ausschalten

Berü

Kein Menü

Bearbeitet am 02.11.2009


Strecke-Menue

Eingleisige Strecken-Menü

Lupe

In der 1. Zeile steht die Bezeichnung der eingleisigen Strecke

  • EA = Erlaubnis abgeben. (Fahrtrichtung wechseln)
  • EH = Erlaubnisabgabe holen - nicht geplant
  • EL = Gespeicherte Erlaubnisabgabe löschen - nicht geplant

Berü

Kein Menü

Neu am 01.07.2007


Gleis-Menue

Gleis-Menü

Lupe

In der 1. Zeile steht die Bezeichnung des Gleises

  • FHA = Fahrstrassenelement auflösen einzeln
  • FHAE = Fahrstrassenelement hilfsweise auflösen einzeln
  • AZG = Fahrstrassenelement zurücksetzten (Grundstellen)

Berü

Kein Menü

Bearbeitet am 02.11.2009


Signal-Menue

Signal-Menü

Lupe

Das Signalmenü ist je nach Signaltyp und Auslegung unterschiedlich, die Typen von links nach rechts: Ausfahrsignal, Einfahrsignal, Blocksignal, Sperrsignal mit Zugstrasse, Sperrsignal, Pfeil. Die Menügruppe SB ist nur bei Konfiguriertem Selbststellbetrieb vorhanden.

Es folgen die Signalgruppen für FPÜ, SB, Stellen und Andere. Für Andere gibt es zwei Varianten, eine große für alle Signale außer Einfahr- und Blocksignale, dafür steht das letzte Bild in der Reihe.

In der 1. Zeile steht die Signalbezeichnung, bei Anwahl werden ein paar Informationen angezeigt. Die weiteren Befehle bedeuten:

  • HaGT = stehlt das Signal auf Stop
  • R oder Z = Schaltet zwischen Rangiermodus (R) und Zugstrassenmodus (Z) um
  • FPÜ = enthält ein Untermenü ohne Funktion (nur Optik)
  • SB = Selbststellbetrieb
    • SBE = Selbststellbetrieb einschalten
    • SBA = Selbststellbetrieb ausschalten
  • Stellen = enthält EE1 und EE2 (später)
  • Andere = Zusätzliche Funktionen
    • FA = Am Signal endende Fahrstrasse auflösen
    • FHA = Fahrstrasse hilfsweise auflösen
    • BHA = Fahrstrasse im Block hilfsweise auflösen
    • SS oder BS = Signal sperren
    • SE oder BE = Signal entsperren
    • DA = Durchrutschweg auflösen - nicht implementiert

2. Menü: Zur Auswahl einer Fahrstrasse wechselt das Menü für die Zielangabe:

  • FP = Fahrstrasse prüfen
  • D-Weg = Gruppe für Durchrutschwege
  • U-Weg = Gruppe für Umfahrstrassen
  • MW = Gruppe für Mittelweichen
  • Andere = Zusätzliche Funktionen
    • F = Fahrstrasse von Oberleitung in Bereich ohne Fahrdraht einstellen
    • S = Fahrstrassensperre umgehen
    • FS = Wie F und S ...
    • ohne = Fahrstrasse normal einstellen

Berü

Auf der Berü werden die Menüs in abgespeckter Version, von links nach rechts: Ausfahr- und Sperrsignale mit Zugstrasse, Einfahr- und Blocksignale, Einfahr- und Blocksignale ohne SB, Sperrsignale. Als letztes das 2. Menü für Fahrstrassenziel, die Gruppe Andere entspricht der Lupe.

Bearbeitet am 02.11.2009


Weichen-Menue

Weichen-Menü

Lupe

In der 1. Zeile steht die Bezeichnung der Weiche

  • WU = Weiche umstellen
  • FPÜ = enthält ein Untermenü ohne Funktion (nur Optik)
  • AZG = Achszähler Grundstellen (Belegtmeldung aufheben)
  • Andere = Zusätzliche Funktionen
    • WUS = Weiche gegen umstellen sperren
    • WUE = Weiche gegen umstellen entsperren
    • WHU = Weichensperre hilfsweise umgehen - später
    • AWU = Aufgefahrene Weiche umstellen - nicht geplant, nur Optik
    • FAE = Fahrstrassenelement auflösen einzeln
    • FHAE = Fahrstrassenelement hilfsweise auflösen einzeln

Berü

kein Menü

Bearbeitet am 02.11.2009


Grundlagen des ESTW

Grundlagen und Regeln der ESTW-Steuerung

In diesem Kapitel werden die Grundlagen dieser ESTW-Steuerung beschrieben. Insbesondere werden die Regeln beschrieben, nach denen diese Steuerung arbeitet bzw. arbeiten soll. Es wird versucht möglichst nahe am Vorbild zu bleiben:

  • Eine Zugstrasse stellen
  • Eine Rangierstrasse stellen
  • Eine Fahrstrassen auflösen
Neu am 22.05.2007


DKW

Kreuzungen und DKW

Einfache Kreuzungen

Einfache Kreuzungen werden ähnlich wie (Pseudo-) Weichen behandelt (Typ 8 und 9), haben aber keinen Antrieb. Es sind trotzdem Maßnahmen zum sperren der Kreuzung erforderlich, um Zusammenstöße zu verhindern. Bei Kreuzungen entfällt der Spitzenmelder, auch können Kreuzungen keinen Flankenschutz geben. Es werden aber zusätzliche für die Ausleuchtung benötigt, das in der Konfiguration die grünen Felder. Diese Melder gelten für den diagonalen Strang der Kreuzung.

Doppelte Kreuzungsweichen (DKW)

DKW sind noch deutlich komplizierter, im Programm werden DKW mit einem Antrieb berücksichtigt. Dieser Antrieb stellt die DKW auf "Gerade" (= rechts) oder auf "Abzweig" (= links). DKW benötigen keinen Spitzenmelder und können keinen Flankenschutz geben. Eine DKW besteht in diesem Programm aus zwei Weichen:

  • Eine Weiche mit Antrieb, das ist immer der rechte Teil auf dem Bild.
    • Typ 10 links /-
    • Typ 12 rechts \-
  • Eine (Pseudo-) Weiche ohne Antrieb, immer der linke Teil auf dem Bild.
    • Typ 11 links -/
    • Typ 13 rechts -\

Beide Zweige werden getrennt geschaltet, zwei Einträge in der Fahrstrasse bzw. zwei Bedienhandlungen mit "WU". Im Stellpult werden für die Typen 12 und 13 die Tastereinträge für WGT und WT getauscht (entspricht nicht dem realen DrSp), ist aber einfach zu handhaben und man benötigt keine zusätzlichen Taster.

Für den Schaltvorgang gelten einfache Bedingungen: beide Weichen in Rechtslage bedeutet für die DKW "Geradeaus" und für den Antrieb Rechtslage (oder Invertiert, wenn die Anschlüsse vertauscht sind). Beide Weichen in gegensätzlicher Lage bedeutet für die DKW "Abzweig" und für den Antrieb Linkslage. Eine DKW wird der Einfachheit halber immer geschaltet, das Kennzeichen "Liegt" ist nur für die Darstellung auf dem Bildschirm von Bedeutung.

Neu am 02.07.2007


Lokumsetzen

Beispiel Lokumsetzen / Entkuppler

Nachfolgend wird eine Anwendung eines Entkupplers gezeigt:

Der Entkuppler ist mit einem grauen Symbol gezeichnet, er wird in der Konfiguration auf der Seite "Sonstiges" angelegt: Typ 6 nur auf der Lupe mit Koordinaten und Richtung. Das Feld Länge enthält 0, Beru muss 0 sein, T1 und T2 sind Taster im Stellpult, Led ist eine Lednummer, darunter steht die Stellzeit in ms. Am Ledausgang ist ein Minirelais installiert, das den elektrischen Entkuppler für die angegebene Zeit einschaltet.

Im Gleis 9 (Block 205) steht eine Lok BR221 mit Anhängern, Gleis 109 ist ein Gleis, das an den Block 205 angeschlossen ist, die Weiche 43 ist über den Belegtmelder 17 mit dem Block 205 verbunden. Dieser Melder ist gleichzeitig der Haltmelder von Block 205. Weiche 43 ist als Mittelweiche definiert, dadurch ist diese Weiche freigeben wenn der Melder 17 nicht belegt ist und keine Fahrstrasse über diese Weiche eingestellt ist. In der Einfahr-Fahrstrasse nach Block 205 wird diese Weiche auf "rechts" gestellt und verriegelt bis diese Fahrstrasse wieder aufgelöst ist. Das geht automatisch.

Zum Entkuppeln fährt man den Zug in die richtige Position, startet den Entkuppler (Stellpult oder Rechte Maustaste-Menü) und fährt die Lok vor (ebenfalls Stellpult oder Mausrad). Die Entkuppleranzeige wechselt für die eingestellte Zeit auf "gelb". Die Lok muss vorfahren bis die Weiche 43 wieder frei ist.

Jetzt können die nächsten Fahrstrassen gestellt werden, im Beispiel nach Sperrsignal 10 und weiter Gleis 9. In der Fahrstrasse von Gleis 109 (Block 205) zum Sperrsignal muss als Signalbild Hp -1 eingetragen sein. Dieser Eintrag bewirkt, dass das Signal N9 von Block 205 nicht gestellt wird.

Die Lok 221 hat die Wagen umfahren.

Neu am 01.10.2007


Zugstrasse stellen

Definition

Fahrstrassen sind das Kernstück einer ESTW-Steuerung, ein Zug fährt immer von einem Startpunkt zu einem Zielort. Man unterscheidet zwischen Zugstrassen, Zughilfsstrassen und Rangierstrassen. Eine Zugstrasse beginnt immer an einem Startsignal und endet an einem Zielsignal, bei Fehlen des Startsignals ist das eine Zughilfsstrasse. Eine Fahrstrasse ist immer vollständig gesichert: Alle Elemente der Zugstrasse sind gegen Umstellen und Flankenfahrten gesichert und frei (nicht belegt). Es gibt drei Arten von Zugstrassen:

Einfahrzugstrasse: Start am Einfahrsignal und Ende am Ausfahrsignal, am Zwischensignal oder in einem Stumpfgleis. Ist das Ziel ein Ausfahr- oder Zwischensignal, so folgt der Durchrutschweg (D-Weg), in dieser Programmversion nicht vorgesehen

Ausfahrzugstrasse: Start am Ausfahrsignal und Ziel am nächsten Hauptsignal

Durchfahrt: Aneinander gereihte Einfahr- und Ausfahrzugstrasse, kann wenn geplant auch direkt gestellt werden

Bedienung

Eine Zugstrasse wird mit dem Befehl "SSS.ZZZ" über die Tastatur oder durch Ankicken von Startsignal und Zielsignal in der Befehlszeile aufgerufen, die Fahrstrasse wird durch betätigen der Taste "Verarbeiten" aufgerufen. SSS steht für das Startsignal, die Bezeichnung besteht aus dem Stellbereich (Bahnhof) und der Signalbezeichnung, z.B. "20N1". Gleiches gilt für das Zielsignal, dazwischen steht ein Punkt (bei Rangierstrassen ein Strich). Besondere Regeln gelten für spezielle Fahrsituationen wie die Fahrt aus einem elektrifizierten Gleis in ein nicht elektrifiziertes Gleis, für Mittelweichen uvm. Diese Besonderheiten sind späteren Versionen vorbehalten.

Prüfung

Als erstes prüft das Programm, ob die geforderte Zugstrasse definiert ist, wenn nicht wird der Befehl abgewiesen. Es folgt die Zulassungsprüfung (ZPZ), das sind:
- Das Fahrstrassenziel ist aufgelöst, Zielfestlegemelder (FZM) in Grundstellung.
- Die Prüfung aller Weichen, wenn der Verriegelungsmelder (WVsM) aktiv ist oder wenn die Weiche gegen umstellen gesperrt (WSpM) ist, muss sich die Weiche in der richtigen Lage befinden. außerdem darf eine Mittelweiche nicht belegt sein.
- In keinem Fahrstrassenelement darf eine Befahrbarkeitssperre eingelegt sein, in dieser Version können nur Signale gesperrt sein.
- In keiner Schlüsselsperre darf ein Schlüssel freigegeben sein (gibt es in dieser Version nicht).
- Der Startblock wird ebenfalls geprüft, denn es darf keine Rangierstrasse aktiv sein, eine Rangierstrasse darf nicht in eine Zugstrasse übergehen. (Eine Zugstrasse darf in eine Rangierstrasse übergehen)
- Als letztes werden alle Überblöcke (incl. Gleise und Bahnübergänge) geprüft. Wenn alle frei sind, kann die Fahrstrasse gestellt werden und der Befehl wird in den Verarbeitungspuffer geschrieben.

Zugstrasseneinstellung

Wegen der Einschränkungen bei der Modellbahn mit nur einem Rechner und sequenzieller Ausführung der Stellbefehle und der sonstigen Aktionen laufen alle Befehle über einen Puffer (Aktionsliste). Diese Liste wird der Reihe nach abgearbeitet. Kommt nun eine Fahrstrasse zur Verarbeitung, muss zunächst eine erneute vereinfachte ZPZ erfolgen. Für die Modellbahn gilt eine weitere Bedingung: Das sind die Doppeltrennstellen, die Befahrbarkeit wird an dieser Stelle zusätzlich geprüft. Sind diese Prüfungen negativ, wird der Befehl zurückgestellt (an das Ende der Liste).
- Bei positiver Prüfung wird die Zugstrasse in allen zugehörigen Elementen vermerkt, das "grüne" Band (bei Rangierstrassen blau) leuchtet auf dem Bildschirm auf.
- Es startet die so genannte Weichenlaufkette (WLK), alle Weichen werden der Reihe nach in die Sollstellung gebracht. Das gilt auch für Flankenschutzweichen (und D-Weg-Weichen).
- In einem zweiten Programmdurchlauf werden jetzt alle Weichen verschlossen, Verschlussmelder (VsM).
- Jetzt beginnt die Fahrstrassenüberwachung (bei der großen Bahn), der FÜM am Start der Fahrstrasse blinkt.
- Die weitere Sicherung (für die Modellbahn ohne Bedeutung) der Fahrstrasse erfolgt. Jetzt werden alle Signale am Fahrweg in Fahrtstellung gebracht.
- Der FÜM zeigt bei vollständig gesicherter Fahrstrasse Ruhelicht und der bzw. die Zielfestlegemelder leuchten am Zielsignal.
- als letztes erfolgt die Fahrtstellung des Startsignals.

Damit der FÜM bei der Modellbahn überhaupt zum Blinken kommt, schalte ich diesen Zustand abweichend zum Vorbild bereits vor der WLK ein.

Zugfahrt

Die Fahrstrasse ist nun zwar eingestellt, das bedeutet aber nicht, dass der Zug nun auch fahren darf. Hier greift ggf. eine Besonderheit der MPC-Steuerung, die Verfügbarkeit der Blöcke insbesondere für Hilfs- und Pseudo- Blöcke. Bevor der Zug fahren kann müssen noch die benötigten Hauptblöcke reserviert werden.
In alle Blöcken des Fahrwegs werden die Zugnummer (vorgemerkt) und die Fahrtrichtung eingetragen. In Hauptblöcken, die die Stromversorgung liefern steht ebenfalls die Zugnummer unter "HBlo". Wenn ein Block besetzt ist, steht die Zugnummer auch im Feld "Akt."
Dann fährt der Zug endlich los!

Besonderheiten

Für Formsignale gelten bei der Modellbahn zusätzliche Ablaufverzögerungen, da diese auch sequenziell gestellt werden müssen. Insbesondere wenn auch Vorsignale und Kombinationen aus Haupt- und Sperrsignal zum Einsatz kommen. Das Programm stellt diese in der Reihenfolge Lichtsignale zusammen mit den Formhauptsignal, dann das Formvorsignal und anschließend das Formsperrsignal.

Die Bedienung der Bahnübergänge (BÜ) wird später beschrieben. BÜ werden geschaltet und gesichert bevor das vorausgehende Signal in Fahrtstellung kommt.

Neu am 22.05.2007


Rangierstrasse

Rangierstrasse stellen

Definition

Fahrstrassen sind das Kernstück einer ESTW-Steuerung, ein Zug fährt immer von einem Startpunkt zu einem Zielort. Man unterscheidet zwischen Zugstrassen, Zughilfsstrassen und Rangierstrassen. Eine Rnagierstrasse beginnt immer an einem definierten Punkt und endet an einem definierten Punkt, Signale müssen nicht aufgestellt sein. In einer Rangierstrasse ist nur der Fahrweg gesichert, der Flankenschutz ist nicht erforderlich. Es darf in belegte Gleise eingefahren werden. Das Rangierstrassenziel muss nicht unbedingt erreicht werden. Eine Rangierstrasse in Gegenrichtung darf eingestellt werden, auch wenn Weichen noch verriegelt sind.

Bedienung

Eine Rangierstrasse wird analog zu Zugstrassen eingestellt, der Befehl unterscheidet sich nur durch einen Bindestrich anstelle des Punktes "SSS-ZZZ". Es ist darauf zu achten, das bei einigen Signalen im Popup-Menü "R" für Rangierstrasse angezeigt wird ("Z" bei Zugstrassen). Der Markierungsrahmen bei Auswahl mit der Maus ist für Rangierstrassen Blau.

Prüfung

Als erstes prüft das Programm, ob die geforderte Rangierstrasse definiert ist, wenn nicht wird der Befehl abgewiesen. Es folgt die Zulassungsprüfung (ZPZ), das sind:
- Das Rangierstrassenziel ist aufgelöst, Zielfestlegemelder (FZM) in Grundstellung.
- Am Rangierstrassenziel darf auch keine Zugstrasse beginnen.
- Die Prüfung aller Weichen, wenn der Verriegelungsmelder (WVsM) aktiv ist oder wenn die Weiche gegen umstellen gesperrt (WSpM) ist, muss sich die Weiche in der richtigen Lage befinden.
- In keinem Fahrstrassenelement darf eine Befahrbarkeitssperre eingelegt sein, in dieser Version können nur Signale gesperrt sein.
- In keiner Schlüsselsperre darf ein Schlüssel freigegeben sein (gibt es in dieser Version nicht).
- Als letztes werden alle Überblöcke (incl. Gleise und Bahnübergänge) geprüft. Wenn alle frei sind, kann die Rangierstrasse gestellt werden und der Befehl wird in den Verarbeitungspuffer geschrieben.

Rangierstrasseneinstellung

Kommt Rangierstrasse zur Verarbeitung, muss zunächst eine erneute vereinfachte Prüfung erfolgen. Für die Modellbahn gilt eine weitere Bedingung: Das sind die Doppeltrennstellen, die Befahrbarkeit wird an dieser Stelle zusätzlich geprüft. Sind diese Prüfungen negativ, wird der Befehl zurückgestellt (an das Ende der Liste).
- Bei positiver Prüfung wird die Rangierstrasse in allen zugehörigen Elementen vermerkt, das "blaue" Band (bei Zugstrassen grün) leuchtet auf dem Bildschirm auf.
- Es startet die so genannte Weichenlaufkette (WLK), alle Weichen werden der Reihe nach in die Sollstellung gebracht. In Sonderfällen kann auch Flankenschutz definiert sein.
- In einem zweiten Programmdurchlauf werden jetzt alle Weichen verschlossen, Verschlussmelder (VsM).
- Jetzt werden alle Signale am Fahrweg in Rangierstellung gebracht.
- als letztes erfolgt die Sh1-Stellung des Startsignals falls vorhanden.

Zugfahrt

Die Rangierstrasse ist nun zwar eingestellt, das bedeutet aber nicht, dass der Zug nun auch fahren darf. Hier greift ggf. eine Besonderheit der MPC-Steuerung, die Verfügbarkeit der Blöcke insbesondere für Hilfs- und Pseudo- Blöcke. Bevor der Zug fahren kann müssen noch die benötigten Hauptblöcke reserviert werden.
In alle Blöcken des Fahrwegs werden die Zugnummer (vorgemerkt) und die Fahrtrichtung eingetragen. In Hauptblöcken, die die Stromversorgung liefern steht ebenfalls die Zugnummer unter "HBlo". Wenn ein Block besetzt ist, steht die Zugnummer auch im Feld "Akt."
Dann kann der Zug endlich fahren!

Besonderheiten

Die Bedienung der Bahnübergänge (BÜ) wird später beschrieben. BÜ werden geschaltet und gesichert bevor das vorausgehende Signal in Fahrtstellung kommt.

Neu am 22.05.2007


Fahrstrassen auflösen

Zugbewirkt

Bei der großen Bahn erfolgt die Fahrstrassenauflösung etwas komplexer. In diesem Programm werden Fahrstrassen nach vereinfachten Regeln aufgelöst:
Im Fahrstrassentableau ist das Prinzip zu sehen, vom Programm werden alle Überblöcke der Reihe nach besetzt, eine 1 im Tableau unter "Bes." Nach Durchfahrt des Zuges werden die Blöcke wieder frei gemeldet, es wird eine 2 eingetragen. Ist bei allen Überblöcken eine 2 eingetragen erfolgt die Freigabe der Fahrstrasse zur Auflösung. Bei Zugstrassen müssen zusätzlich der Startblock frei und der Zielblock besetzt sein.

Zugfahrt

Bevor der Zug das Ziel erreicht wird die Fahrstrasse bereits teilweise zurückgenommen:
- Bei Besetztmeldung des ersten Überblockes erlischt der Fahrstrassenüberwachungsmelder.
- Bei Freimeldung der Abschnitte wird deren Status auf 0 zurückgestellt
- Die Signale werden nach Vorbeifahrt in Haltstellung gebracht

Zugbewirkte Fahrstrassen-Auflösung

Nachdem alle Abschnitte frei gemeldet wurden erfolgt die vollständige Auflösung der Fahrstrasse:
- Im Zielblock wird die Fahrstrassen Markierung gelöscht (Bit 2 und 4).
- Im Startblock werden Status und Zugeinträge zurückgesetzt.
- In allen Überblöcken werden ebenfalls Status und Zugeinträge gelöscht.
- alle Verschlussmelder (VsM) werden zurückgesetzt. - Das Startsignal wird komplett zurückgesetzt (diverse Merker) und vorsichtshalber noch einmal auf Halt gestellt.
- Merker im Zielblock und am Zielsignal werden ebenfalls zurückgenommen.
- An den Weichen werden die Verschlussmelder (VsM) und Flankenschutzmelder (ShM) decrementiert.
- Die Leds in der Liste der Fahrstrasse werden ausgeschaltet.
- Eine evtl. vorhandene Eingl. Strecke wird gepflegt. (Eingl. Strecke ist noch nicht fertig)
- Wenn nötig werden die Trennstellen zurückgesetzt. - Zum Schluss wird noch der Zielfestlegemelder zurückgesetzt.

Besonderheiten

Bahnübergänge werden später beschrieben.

Neu am 23.05.2007


Befehle

Befehle und Abkürzungen

In diesem Kapitel soll eine Übersicht der Befehle gegeben werden und weitere Informationen, wenn nötig:

Befehl | Beschreibung | Gruppe | Beispiel | Status
xx.xx | Zugstrasse stellen | Fahrstr. | 20N3.20NZ | ok
xx-xx | Rangierstrasse stellen | Fahrstr. | 20Y5-20G12 | ok
F,xx.xx | Zugstrasse in Bereich ohne Fahrdraht stellen *) | Fahrstr. | 20Y5-20G12 | ok
F,xx-xx | Rangierstrasse in Bereich ohne Fahrdraht stellen *) | Fahrstr. | 20Y5-20G12 | ok
AWU | Aufgefahrene Weiche umstellen | Weichen | AWU,20W32 | nein
AZG | Achszähler Grundstellen (Block freimelden) | Gleise | AZG,G12 | ok.
BE | Blocksignal entsperren | Signale | BE,15F | ok
BS | Blocksignal sperren | Signale | BS,15F | ok
BHA | Block hilfsweise auflösen | Signale | BHA,14F | ok
DA | Durchrutschweg auflösen | Signale | DA,15F | Menü, evtl.
DHA | Durchrutschweg hilfsweise auflösen | Signale | DHA,15F | nein
EA | Erlaubnis abgeben (Richtungswechsel Eingl. Strecke) | Strecke | EA,BG | ok
EE1 | Ersatz- oder Vorsichtssignal ohne Sperr. der WKL | Signale | EE2,15F | evtl.
EE2 | Ersatz- oder Vorsichtssignal mit Sperr. der WKL | Signale | EE2,15F | evtl.
EH | Erlaubnis holen | Strecke | EH,BG | Menü, nein
EL | gespeicherte Erlaubnisabgabe löschen | Signale | EL,15F | Menü, nein
FA | Fahrstrasse auflösen | Signale | FA,15F | ok
FAE | Fahrstrassenauflösung Einzelelement | - | FAE,15W53 | ok
FESP | Fahrstrasseneinzelelement entsperren | - | FESP,15W53 | nein
FHA | Fahrstrasse hilfsweise auflösen | Signale | FHA,15F | ok
FHAE | Fahrstrassenhilfsauflösung Einzelelement | Signale | FHAE,15W53 | ok
FHT | Zugstrasse hilfsweise auflösen | - | FHT,10N1.12N2 | evtl.
FHU | gestörte Flankenschutzeinrichtung hilfsweise umgehen | Signale | FHU,20W32 | nein
FP | Fahrstrasse prüfen | - | FP,10N1.12N2 | evtl.
FRT | Fahrstrasse ohne Festlegung auflösen | - | FRT,10N1.12N2 | evtl.
FSP | Fahrstrassenelement sperren | - | FSP,15W53 | evtl.
GHU | gestörte Gleisfreimeldeeinrichtung hilfsweise umgehen | Signale | GHU,15F | nein
HaGT | Lichtsignal auf Halt stelle (Form auch) | Signale | HAGT,15F | ok
LSA | Sperrsignale auf der Berü ausblenden | Bahnhof | LSA | ok
LSE | Sperrsignale auf der Berü anzeigen | Bahnhof | LSE | ok
MA | Merkhinweis anzeigen | - | MA,20W32 | nein
ME | Merkhinweis eingeben | - | MA.. | nein
ML | Merkhinweis löschen | - | ML.. | nein
NE | Nachtspannung der Signale einschalten | Bahnhof | NE | evtl.
SBA | Selbststellbetrieb ausschalten | Signale | SBA,15F | ok
SBE | Selbststellbetrieb einschalten | Signale | SBE,15F | ok
SE | Signal entsperren | Signale | SE,15F | ok
SGT | Fahrtrichtungseinschaltung bei ZB | Signale | SGT,... | nein
SS | Signal sperren | Signale | SS,15F | ok
TE | Tagspannung der Lichtsignale einschalten | Bahnhof | TE | evtl.
THU | gestörte techn. Einrichtung im Fahrweg hilfsweise umgehen | - | THU,20W32 | nein
UA | Bahnübergangssicherung ausschalten (BÜ öffnen) | BÜ | UA,15U03A | ok
UAE | Automatisches Einschalten der Bahnübergangssicherung entsperren (BÜ auf Automatik) | BÜ | UAE,15U03A | ok
UAS | Automatisches Einschalten der Bahnübergangssicherung sperren (BÜ Automatik aus) | BÜ | UAS,15U03A | ok
UDA | Bahnübergangssicherung auf Dauer ausschalten | BÜ | UDA,15U03A | ok
UDE | Bahnübergangssicherung auf Dauer einschalten | BÜ | UDE,15U03A | ok
UE | Bahnübergangssicherung einschalten (BÜ schliessen) | BÜ | UE,15U03A | ok
UF | Bahnübergang mit vollem Schrankenabschluss freimelden | BÜ | UF,15U03A | nein
VE1 | Vorsichtssignal bedienen (WLK nicht gesperrt) | Signale | VE1,15F | evtl.
VE2 | Vorsichtssignal bedienen (WLK gesperrt, FÜM dunkel) | Signale | VE2,15F | evtl.
WLE | Weichenlaufkette entsperren | Bahnhof | WLE,20 | nein
WLS | Weichenlaufkette sperren | Bahnhof | WLS,20 | nein
WHU | Weiche hilfsweise umstellen | Weichen | WHU,20W32 | evtl.
WU | Weiche umstellen | Weichen | WU,20W32 | ok
WUE | Weiche zum Umstellen entsperren | Weichen | WUE,20W32 | ok
WUS | Weiche gegen Umstellen sperren | Weichen | WUS,20W32 | ok
ZLA | Zuglenkung ausschalten | - | ZLE,20 | evtl.
ZLE | Zuglenkung einschalten | - | ZLE,20 | evtl.

ok = bereits fertiggestellt
unf. = begonnen, aber noch nicht fertig gestellt
geplant = wird in dieser Version enthalten sein
später = nicht in der 1. Programmversion
evtl. = kommt wahrscheinlich - noch offen
nein = nicht vorgesehen
Menü = steht zur Zeit im Menü
*) für Fahrstrassen die aus einem elektrifizierten Bereich in einen Bereich
ohne Oberleitung führen

MPC-Befehle (nicht ESTW)

Befehl | Beschreibung | Gruppe | Beispiel | Status | Pult
GNothalt | Generalnothalt | Fahrpult | direkt | ok | ok
Rangieren | Umschalter Rangiermodus ein/aus | Fahrpult | direkt | ok | ok
#F, | Fahrregler von Block xxx auswählen | Fahrpult | #F,123 | ok | * Blk
#F | Fahrregler xxx direkt auswählen | Fahrpult | #F005 | ok | 3x12er
#A | Anfahrbeschleunigung | Fahrpult | #A10 | ok | a+2T
#B | Bremsverzögerung | Fahrpult | #B5 | ok | b+2T
#C | Bremsverzögerung im Haltepunkt | Fahrpult | #C2 | ok | c+2T
#S | Schleichgeschwindigkeit | Fahrpult | #S8 | ok | sch+2T
#O | Max. Geschwindigkeit | Fahrpult | #O90 | ok | max+2T
#U | Min. Geschwindigkeit | Fahrpult | #U22 | ok | min+2T
#HP2 | Hp2-Geschwindigkeit | Fahrpult | #HP28 | nur Pult | hp2+2T
#HP3 | HP3-Geschwindigkeit | Fahrpult | #HP38 | evtl. | hp3+2T
#S,xxxx.0 | Schalter Nummer xxxx ausschalten | Allgemein | #S,601.0 | ok | ok
#S,xxxx.1 | Schalter Nummer xxxx einschalten | Allgemein | #S,601.1 | ok | ok

2T = 2 Tasten des 12er Block

Bearbeitet am 13.05.2015


Tutorial Seite2

Konfiguration

Konfiguration öffnen, es erscheint die Config-Seite mit den Minimaleinstellungen: 1 Blockkarte, 1 Hilfsblockkarte, 1 Belegtmelderkarte und eine Weichenkarte. Es sind eine Lupe und eine Berü vorgegeben, der Zeitgeber steht auf 20, 20, 100.

Für die weiteren Arbeiten werden 2 Blockkarten eingestellt und die Config gesichert, jetzt gibt es auch eine ini-Datei.

1. Block anlegen

Ein Klick auf den Reiter Block öffnet die entsprechende Seite. Wichtig sind hier die beiden Felder mit den roten Ziffern "Lupe/Berü". Vor eingestellt ist hier jeweils eine 1, das sind die Bildschirmseiten auf denen ein Symbol erzeugt wird. Hier muss vor dem anklicken des Schalters "Neu" die richtige Seite stehen. Eine nachträgliche Änderung wird immer erst nach einem Neustart des Programms wirksam! (Daten sichern, Programm beenden, neu starten, Daten laden)

Gleis 1 Das erste Gleis wird mit der Taste "Neu" erzeugt. Wir beantworten die Frage nach der Blocknummer mit "1" und bestätigen. Jetzt gibt es auf der Lupendarstellung (kurz "Lupe") und der Bereichsübersicht (kurz "Berü") das erste Symbol.

Wir wechseln einmal zwischen Lupe und Berü: Das geht einmal über das Menü Anzeige oder einfacher mit den Cursor-Tasten: Cursor nach oben gefolgt von rechts/links schaltet auf die Berü, Cursor nach unten gefolgt von recht/links schaltet auf die Lupe. Nur recht/links schaltet zwischen Lupen bzw. Berü um.

Ein Klick mit der rechten Maustaste auf das Gleis öffnet ein Menü, diese sind verschieden auf Berü und Lupe. In der ersten Zeile steht der Bezeichner, in diesem Fall "10G1", das steht für den Bahnhofsbereich 10 (muss 2-stellig sein), für Gleis und die Nummer des Gleises (das hat nichts mit der Blocknummer zu tun). Jeder Bezeichner darf insgesamt nur einmal vorkommen.

Auf der Lupe: Das Symbol ist ein Hauptgleis mit einem Verschlussmelder (VsM), das ist die weiße Spitze. Es gibt 3 Gleistypen 0-2 (1 = einfaches Gleis weiß, 2 = weiß gestrichelt). Wir benötigen den Typ "0". Verändern wir mal den Status zum besseren Verständnis nach 0,1,2,4,8: Das bedeutet Frei, Belegt, Zugstrasse, Rangierstrasse oder einfach weiß. Das Feld "Gleis" steht für ein Gleis ohne Verschlussmelder. Die internen Marker ZFM v/r zeigen einen Zielfestlegemelder in Vorwärts- bzw. Rückwärts-Richtung an, das ist ein grüner Punkt am jeweiligen Gleisende. Wichtig ist noch für den Betrieb das Feld "Invert": Es legt die MPC-bezogene Fahrtrichtung fest, nicht markiert bedeutet, Fahrtrichtung vorwärts von links nach recht; markiert umgekehrt. Weitere Erklärungen folgen später.

Jetzt positionieren wir das Gleis mit den Angaben für die Lupe Position X = 350, Position Y =100, Länge = 120, Für die Berü 300, 100, 80. Das Symbol steht jetzt an der neuen Stelle auf den Bildern.

Wir sichern die Einstellung mit "Daten sichern" als "Test.dat".

Signale erstellen

Signal N1 Auf der Seite Signale geben wir als Bereich "10" ein und für die Signal-Bezeichnung "N1", Lupe und Berü ist jeweils die "1". "Neu" drücken. Das Signal kommt nach Position 470/100, die Länge ist 30. Ein zweites Signal "P1" wird erzeugt. Das kommt nach 360/100 mit Länge 30. Mit einer "1" im Feld Richtung wird das Signal umgedreht (Die Positionsberechnung muss von mir für einige Symbole noch mal überarbeitet werden) Position X jetzt anpassen auf 340. Beide Signale gehören zum Block 1 - war die Voreinstellung. Beide Signale stehen auch in der Auswahlliste rechts.

Jetzt müssen die Signalnummern noch im Blockformular eingetragen werden: Die grünen Felder im Block "1". Es gibt ein Signal in Vorwärts-Richtung und ein Signal in Rückwärtsrichtung (nicht rechts/links). Unter Signal Idx. Schreiben wir 1 für rückwärts und 0 für vorwärts.

Die Signale müssen noch auf der Berü platziert werden. N1 = 380,100,30 und P1 = 279,100,30
-> Sichern

Nächster Block

Es folgen der Block Nummer 2 mit 350,140,120 für die Lupe und 300,130,80 für die Berü. Dazu kommen zwei weitere Signale: "10N2" = 470,140,30 und 380,130,30; "10P2" = 340,140,30 und 279,130,30 mit Richtung 1 und Blocknummer 2.

2 Gleise Bis jetzt existieren zwei Gleise, das sollen die Gleise für den Bahnhof "Test" sein. An beiden Enden steht jeweils ein Hauptsperrsignal mit vielfältigen Möglichkeiten. Wer mag kann mal mit den Feldern Typ (0-9), Stellung (0-3), SB-Akt. (0-2), Zs1M/Zs7M (0-2), SSpM, markiert, FüM und FüM + Blk experimentieren, die Anzeige und auch die Programmausführung benutzen diese Felder. Die Menü-Anzeigen funktionieren ebenfalls schon. Mit einem Kick auf den Bezeichner im Menü bekommt man eine Info in der Infozeile im Hauptfenster unten.

weiter auf Seite 3

Neu am 9.07.2007


Tutorial Seite 3

Weichen

Wir wechseln auf die Tabelle Weichen und legen die ersten Weichen an, auf der Lupe:
Weiche 1: Typ 1, Position 280,140, Abstand 1, Länge Spitze 20, Gerade 30, Abzw. 30.
Weiche 2: Typ 3, Position 530,140, Abstand 1, Länge Spitze 20, Gerade 30, Abzw. 30.
Auf der Berü:
Weiche 1: Position 250,130, Abstand 1, Länge Spitze 10, Gerade 30, Abzw. 30
Weiche 2: Position 400,140, Abstand 1, Länge Spitze 10, Gerade 30, Abzw. 30
-> sichern

Jetzt kann man schon mal mehrere Befehle probieren, dazu MPC einschalten. Mit der rechten Maustaste eine Weiche anklicken und im Popup-Menü den Befehl "WU" anklicken, in der Eingabezeile steht jetzt: "WU,10W1", das ist der Befehl zum Umstellen der Weiche. Der Befehl kann auch mittels Tastatur direkt eingegeben werden. Mit Verarbeiten wird der Befehl ausgeführt, falls erlaubt. Die Weichenanzeige zeigt jetzt eine eindeutige Stellung an. Für die MPC gibt es neben der normalen Stellungsanzeige noch die Anzeige Stellung unbekannt bzw. nicht sicher, beide Stränge sind unterbrochen. Das ist der Zustand nach jedem Programmstart.

Testen wir mal einen weiteren Befehl im Popup-Menü unter "Andere -> WUS" = Weiche gegen Umstellen sperren. Der Weichenbezeichner ist jetzt rot hinterlegt. Versucht man wieder, die Weiche umzustellen, so wird der Befehl "WU" jetzt abgewiesen. Mit dem Befehl "WUE" ebenfalls unter "Andere" wird die Sperre zurückgenommen. Dieser Befehl ist KF-pflichtig (= Kommandofreigabe), deshalb müssen nach "Verarbeiten" noch die Tasten "KF1" und "KF2" bedient werden; beim Original-ESTW sogar in einem festgelegten Zeitfenster, sonst wird der Befehl annulliert.

Die Weichen benötigen noch einen Link auf den zugehörigen Block, sonst stimmt nachher die Anzeige nicht: Weiche 1 bekommt im Feld Block eine 3 und Weiche 2 gehört zum Block 4.

Weiterer Ausbau

Es werden weitere Blöcke und Signale in der Reihenfolge hinzugefügt:
Block 3: Bez. Und Zugnummer = 92, Lupe 200,140,60; Berü 200,130,50
Block 4: Bez. Und Zugnummer = 12, Lupe 560,140,60; Berü 430,130,50
Signal 10A Typ = 2, Richtung = 0, Lupe 170,140,30 Berü 185,130,30, Block 201
Signal 10F Typ = 2, Richtung = 1, Lupe 640,140,30 Berü 480,130,30, Block 202
Block 201: Bez. Und Zugnummer = P, Lupe 90,140,80; Berü 100,130,75
Block 202: Bez. Und Zugnummer = N, Lupe 650,140,80; Berü 505,130,75

RSig Weiterhin benötigen wir für Rangierfahrten entsprechende Signale, hier sollen zwei verschiedene Möglichkeiten gezeigt werden. Auf der linken Seite erzeugen wir nur Rangierpfeile ohne echte Signale:
Signal 10G92, Block 3, Typ 8, Richtung 4, Lupe 220,140; Länge 22 beschreibt den Abstand der beiden blauen Pfeile. Das Feld Vorsignal wird bei Typ 8 für Textattribute missbraucht = 2 für gelben Text (0 = kein Text). Das ist jetzt ein Start- und Zielpunkt für Rangierstrassen.

SperrSig Auf die rechte Seite kommt zur Abwechselung ein echtes Sperrsignal:
Signal 10G12, Block 4, Typ 5, Richtung 1, Lupe 560,140, 22. Das ist jetzt ein Signal, an dem eine Rangierfahrt in Richtung Bahnhof beginnen kann, aber wir benötigen auch noch ein Ziel:
Signal 10G12A, Block 4, Typ 8, Richtung 0, Lupe 570,140,10. Auf der Berü sind diese Signale noch nicht sichtbar.

Als letzte "Signale" nur für die Ausfahrt benötigt man noch den Typ 7 (Zielpfeile genutzt als Ausfahrziel aus einem Bahnhof):
Signal 10AD, Typ 7, Richtung 1, Vorsig. 1, Lupe 120,140,18, Berü 172,130,30, Block 201
Signal 10BD, Typ 7, Richtung 0, Vorsig. 1, Lupe 660,140,18, Berü 494,130,30, Block 202
-> sichern

weiter auf Seite 4

Neu am 9.07.2007


Tutorial Seite 4

Bahnhof einrichten

Bahnhof Nun benötigt man noch einen Bahnhofsbezeichner, der wird im Formular Sonstiges angelegt mit Typ = 0 und Bereich "10", Key-Text "Test", Text1 "Bhf. ", Text2 "TE" auf Position 335,30 für die Lupe und 290,50 für die Berü, die Felder Länge und Höhe sind ohne Bedeutung. Den Zugspeicher lassen wir in Ruhe.

Wir sichern und beenden das Programm, nach dem Neustart ist jetzt die Menüfunktion des Bahnhofs aktiviert. Wir wechseln auf die Berü (Bereichsdarstellung). Im Menü des Bahnhof (Bahnhofstext) gibt es den Punkt "LSE" Lichtsperrsignale einblenden. Die Signale erscheinen nun alle auf einem Haufen und können platziert werden:
Signal 10G92 Berü 198,130,45;
Signal 10G12 Berü 425,130,10;
Signal 10G12A Berü 467,130,10.
Anschließend werden die Signale mit LSA wieder ausgeblendet.

Als letztes legen wir noch wenig Verzierung an: Diesmal in der Tabelle Gleise noch zwei Dummygleise ohne Funktion:
Gleis 10D1, Typ 8, Lupe X,Y 10,140, Gesamtlänge 80, Berü X,Y 20,130, Gesamtlänge 80
Gleis 10D2, Typ 8, Lupe X,Y 730,140, Gesamtlänge 80, Berü X,Y 581,130, Gesamtlänge 70

Dann noch unter Sonstiges einen Bahnsteig:
Bereich 10, Typ 2, Key-Text Bahnsteig, Lupe 380,115,60, Höhe1, Berü 310,112,60, Höhe 1

Und zwei Richtungspfeile; Bereich 10, Typ 4, Key-Text PAD, Text1/2 AD,AD, Lupe 10,150,50, Höhe 3, Berü 20,135,50, Höhe 3
Bereich 10, Typ 4, Key-Text PBD, Text1/2 BD,BD, Lupe 763,150,50, Höhe 2, Berü 603,135,50, Höhe 2

Damit ist das Bild fertig. Es könnte ein an ein ESTW angepasster Kreis sein die Züge fahren nach B-Dorf (BD) und tauschen sofort bei A-Dorf wieder auf (AD). Zugegeben nicht besonders attraktiv, aber es geht ja um eine Übung. Später machen wir noch einen richtigen Kreis davon mit Schattenbahnhof.
-> sichern

Fahrstrassen

Zum Fahren benötigt man nun noch einige Fahrstrassen. Dazu muss die Seite Strasse geöffnet werden. Wir legen mal eine Ausfahrstrasse von N1 nach B-Dorf an, wie der Befehl aussehen muss, zeigt uns der folgend Versuch. Wir klicken nacheinander das Signal N1 und den grünen Pfeil BD an, beide haben jetzt einen grünen Rahmen und in der Befehlszeile steht: "10N.10BD". Das ist gleichzeitig die benötigte Kennung. Wir schreiben "10N1.10BD in das Feld Kennung und drücken "Neu". In "von Block" muss der Startblock stehen = 1, in "nach Block" der Zielblock = 201 - es soll ja nur im Kreis gefahren werden. Jetzt jeweils ein Doppelklick auf die Felder Signal Start/Ziel. Im 1. Feld steht jetzt eine 0, im 2. Feld verbleibt die -1. Erstmal Übernehmen drücken, sonst sind die Daten verloren, denn die Blockeinstellung stimmt noch nicht.

Im Block 201 fehlen noch die Angaben für den Hauptblock = 3 und für das Signal vorwärts = 4. Zurück zur Fahrstrasse, ein erneuter Doppelklick auf das Feld "Sig. Ziel" und jetzt steht da die 4.

Es fehlen noch die Einträge für die Weichen, im obersten Feld der Liste "2R" für Weiche 2 rechts schalten eintragen. Außerdem fehlen noch die Überblöcke: In der 1. Zeile Num = 4 und Typ = B (für Hauptblock), in der zweiten Zeile Num = 202 und Typ = "H" für Hilfsblock. Die Dummy-Gleise haben keine Funktion und werden nicht eingetragen.

Die erste Fahrstrasse ist fertig konfiguriert: Zum testen, falls in der Eingabezeile noch etwas steht mit "Abbrechen" löschen. Dann "MPCein" drücken und Signal N1 und Pfeil BD anklicken, in der Eingabezeile steht wieder "10N1.10BD" (dieser Befehl kann auch mit der Tastatur eingeben werden). Drücken von Verarbeiten führt jetzt den Befehl aus. Wenn alles richtig ist, leuchtet nun ein grünes Band vom Signal N1 bis zum Signal A, die Weiche 2 ist auch in der richtigen Lage. Doch halt, es gibt eine Lücke bei dem Signal F: hier fehlen noch Einstellungen im Block 202!

Die Fahrstrasse kann wieder aufgelöst werden: Als erstes das Signal mittels Menübefehl "HaGT" (in der Eingabezeile steht "HAGT,10N1" - mit Verarbeiten ausführen) auf Halt stellen. Dann Im Menü des Signals F den Befehl unter "Andere" "BHA" Block Hilfsweise auflösen betätigen. Dieser Befehl ist KF-pflichtig, deshalb die Reihenfolge "Verarbeiten" - "KF1" - "F2" betätigen. Das grüne Band verschwindet.

Nun den Block 202 ergänzen: Hauptblock = 4, Sig. Rückw. = 5. Ein erneuter Test beschert uns nun ein vollständiges grünes Band. Im Gleis P ist auch der grüne Punkt zu sehen (Zielfestlegemelder) und am Signal N1 der "FÜM" (Fahrstrassenüberwachungsmelder), dieser blinkt während des Einlaufens der Fahrstrasse, in den Gleisen sind die Verschlussmelder geschaltet (grüne oder gelbe Spitze), die Weiche 2 ist ebenfalls verschlossen (Verschlussmelder ist das Viereck in der Mitte).

In gleicher Weise müssen noch die folgenden Zugstrassen angelegt werden, Kennung: 10N2.10BD, 10A.10N1, 10A.10N2 und mit einer 2 im Feld Richtung MPC 10P1.10AD, 10P2.10AD, 10F.10P1, 10F.10P2 . Damit sind alle Zugstrassen fertig gestellt, es muss jetzt aussehen wie in der Datei "Test01.dat".

weiter auf Seite 5

Neu am 9.07.2007


Tutorial Seite 5

Rangierstrassen

Was noch fehlt, sind Rangierstrassen, wie die nötigen Befehle aussehen sieht man, wenn man wiederum zwei Signale anklickt. Bei vielen Signalen können sowohl Zugstrassen als auch Rangierstrassen beginnen, deshalb muss in diesem Fall erst auf Rangiermodus geschaltet werden. Dazu z.B. im Menü (rechte Maustaste) des Signals N1 den Punkt "R" anklicken, dadurch wird der Rangiermodus eingestellt. Bei erneutem Aufruf steht nun ein "Z" im Menü, damit wird auf Zugstrassenmodus geschaltet.

Im Rangierstrassenmodus klicken wir auf das Signal 10N1 und auf das Signal 10G12A (Das ist der blaue Pfeil rechts). Beide Symbole haben nun ein blaues Kästchen und in der Eingabezeile steht "10N1-10G12A", eine Rangierstrasse hat zwischen Start- und Zielpunkt einen Bindestrich (bei der Zugstrasse ist dort ein Punkt). Im grünen Feld Rangierstrasse kommt eine 1. Ansonsten ist die Anlage dieser analog zum vorhergehenden Abschnitt. Es werden die folgenden Rangierstrassen benötigt:
10N1-10G12A, 10N2-10G12A, 10G12-10P1, 10G12-10P2, 10G92-10N1, 10G92-10N2, 10P1-10G92, 10P2-10G92.

Damit ist die Anlage aller Fahrstrassen fertig - man kann diese jetzt testen. Rangierstrassen können ohne "HaGT", mit dem Befehl "FA" am Ziel zurückgenommen werden. Oder nach "HaGT" mit "FHA". Alles muss nun aussehen wie in der Datei "Test02.dat".

Züge

Es fehlen noch die Züge, wir wechseln in der Konfiguration auf die Seite "Zug" und betätigen "Neu", geben eine "1" ein und bestätigen. In der Liste steht jetzt "001". Es fehlt jetzt noch eine Eingabe im Feld Name und ggf. im Feld Zug-Nummer. Wir schreiben in beide Feldern "E101" und übernehmen. Dann legen wir noch einen zweiten Zug an "E110".
-> sichern (entspricht "Test03.dat")

Zug Jetzt kommt der Zug auf das Gleis: Dazu schalten wir MPC ein und öffnen in der Konfiguration die Seite MPC2, hier kann der Fahrbetrieb ein wenig simuliert werden: In der Liste "BlockMel" simuliert man mit einem Klick auf "001" eine Belegtmeldung von Block 1, dargestellt durch ein X und Gleis 1 leuchtet jetzt rot. Als nächstes wird mit dem kleinen Schalter "Zug" im Fahrregler unten rechts eine Box geöffnet, da geben wir unter Lok-Nr. eine 1 ein und unter Block ebenfalls eine 1, unter Zug-Nummer tragen wir "E101" ein (das ist der Text der im Gleis angezeigt wird) und bedienen Zug zuordnen.

Jetzt passiert einiges, die Zug-Nummer steht anstelle der Gleisnummer im Gleisplan, in der Liste rechts steht jetzt ebenfalls der Zug mit der Fahrreglernummer angezeigt und im Fahrregler unten steht auch die Fahrreglernummer. Zur vollständigen Anzeige muss aber noch auf den Fahrregler in der Liste rechts geklickt werden, damit wählt man den Zug für den Regler aus. Auf der linken Seite im Fahrregler stehen die Eigenschaften, dieser Teil kann über das Hauptmenü unter Anzeige ein- und ausgeblendet werden.

Der Punkt "Alles sichern" schreibt auch den Betriebszustand in eine Datei mit der Endung "bda". Dieser Zustand steht jetzt in den beiden Dateien "Test03.dat /.bda".

Simulation Fahren

Nun soll der Zug eine Runde fahren (Ausgangsdaten: Test03 mit Alles laden, MPCein): Fahrstrasse von P1 nach AD aufrufen (Signale anklicken und verarbeiten), das grüne band leuchtet auf, mit dem Mausrad oder am Schieber im Fahrregler eine Geschwindigkeit einstellen und auf den kleine roten Pfeil klicken, damit die Fahrtrichtung stimmt. Dann nimmt der Zug die Fahrstrasse auf, in der Blockfolge steht 1, 3, 201, 202; die 1 ist grün hinterlegt (= besetzt und Fahrt). In den Feldern darunter stehen Halte- und Bremspunkte für den Zug, der nächste Haltepunkt in Fahrrichtung rückwärts ist der Block 202.

Wir simulieren die Fahrt. Auf der Seite MPC2 Klick auf BlockMel 003, Block 3 und die Weiche 1 leuchten rot (wenn die Weiche grün bleibt, fehlt noch der Meldereintrag bei der Weiche). Doppelklick auf 001 schaltet diese Belegtmeldung aus. Das grüne Feld in der Blockfolge ist nun vorgerückt. Weiter mit Klick auf HBlockMel 201 und Doppelklick auf BlockMel 003. Man sieht die Weiche ist noch verriegelt (grüner Melder). Weiter mit Klick auf 202 und Doppelklick auf 201. Zug hält an und die Fahrstrasse wird gelöscht, ebenso die Blockfolge: Es gibt nur noch eine rote 202 im Fahrregler.

Die kleinen Symbole vor der Geschwindigkeitsanzeige zeigen, dass "Halt" für den Zug gesetzt ist = rotes "o" oder dass "Schleich" gesetzt ist oliv farbiges "o".

Zum Abschluss lassen wir den Zug noch nach Gleis 2 fahren: Fahrstrasse von F nach P2. Bei richtiger Konfiguration zeigen das Signal F grün und das Signal G12 weiß. Wenn der Zug nach Block 4 vorgefahren ist, zeigt das Signal F wieder Hp0, Signal G12 noch Sh1 (muss ja auch). usw. Dieser Zwischenstand ist in "Test04" hinterlegt.

weiter auf Seite 6

Neu am 9.07.2007


Tutorial Seite 6

Rangieren und Haltepunkte

Beim Rangieren wird man eine unbefriedigende Ausleuchtung der beiden Weichen erkennen, da diese an den gleichen Block gekoppelt sind wie die Enden der Rangierstrassen. Die Ausleuchtung der Weichen ist zwar an die Fahrstrassen gekoppelt, trotzdem bleibt es bei dieser Situation.

Deshalb ordnen wir den Weichen Belegtmelder zu Weiche 1 bekommt im Feld Melder noch eine 1 eingetragen und Weiche 2 eine 2. Jetzt ist die Ausleuchtung schon deutlich verbessert, aber immer noch nicht ideal. Deshalb greifen wir in die Trickkiste ohne zusätzliche Hardware:
Wir legen zwei neue Pseudo-Blöcke an mit den Nummern 301 und 302:
Block 301: Hauptblock = 3; HPr,HPv,BPr,BPv = 1; Gleis = x
Block 302: Hauptblock = 4; HPr,HPv,BPr,BPv = 2; Gleis = x

Die Weiche 1 erhält im Feld Block den Eintrag 301, die Weiche 2 den Eintrag 302. In allen Fahrstrassen müssen diese Blöcke als Überblöcke mit dem Typ P hinzugefügt werden und zwar in der Reihenfolge der Fahrt (anders als bei der MPC).

Jetzt werden die Blöcke noch mit Haltepunkten HPr und HPv (rückwärts/vorwärts) und mit Bremspunkten BPr und BPv (rückwärts/vorwärts) bestückt:

Block 1: HPr = 3; HPv = 4
Block 2: HPr = 5; HPv = 6
Block 3: HPr = 7
Block 4: HPv = 8
Block 201: HPv = 9; BPv = 10
Block 202: HPr = 11; BPr = 12

Jetzt halten die Züge erst bei Belegung der Haltepunkte und bremsen bei Belegung der Bremspunkte oder des Blockes (analog zur MPC). Diese Konfiguration steht in den Dateien "Test05".

Noch ein paar Anmerkungen:

Blöcke werden auch als besetzt angezeigt, wenn einer seiner Halte- oder Bremspunkte besetzt ist. Die Pseudoblöcke 301 und 302 haben keine eigene Besetztmeldung, nutzen aber die Funktionalität der Blöcke, in diesem Fall nur für die Weichen - diese Blöcke können selbstverständlich auch auf der Lupe und / oder der Berü dargestellt sein. Das kann bei großen Weichenstrassen nützlich sein.

In diesem Tutorial ist die Darstellung ins Nirwana verband, weil nicht benötigt; dafür sind die Lupe 0 und die Berü 0 (Diese werden niemals angezeigt)

Viel Spaß beim weiteren Testen bzw. Simulieren.

Neu am 9.07.2007